Aktuelle Uhrzeit in Tabellen verwenden

13. April 2010
Martin Althaus Von Martin Althaus, Excel, Office ...

Wie Sie die aktuelle Zeit in Berechnungen einbeziehen

In einer Tabelle soll eine vorgegebene Zeit mit der aktuellen Zeit verglichen werden. Abhängig vom Ergebnis ist dann ein Datum auszugeben. Solche Modelle sind beispielsweise beim Vermieten von Maschinen und Geräten üblich, wenn nur komplett genutzte Tage berechnet werden. Konkretes Beispiel: Die Vergleichszeit (18:00) steht in der Zelle A2. In der Zelle B2 wird mit der Funktion JETZT die aktuelle Zeit angezeigt.

In der Zelle C2 soll das aktuelle Datum ausgegeben werden, wenn die aktuelle Zeit kleiner ist als die Vergleichszeit. Liegt die aktuelle Zeit hinter dem Vergleichswert, ist die Ausgabe des Datums des folgenden Tages erforderlich.

Alle Versuche, diese Aufgabenstellung mit einer einfachen WENN-Abfrage zu lösen, die beide Zellinhalte vergleicht, schlagen fehl.

Das liegt daran, dass die Funktion JETZT nicht, wie zu erwarten wäre, nur die Uhrzeit liefert, sondern immer auch das dazugehörige Datum.

Sie müssen also bei der Abfrage die aktuelle Zeit in der Zelle B2 durch die Subtraktion von HEUTE von JETZT errechnen. Die komplette Formel für das Beispiel mit dem oben beschriebenen Tabellenaufbau sieht dann folgendermaßen aus (C2):

=WENN(B2>=A2;HEUTE()+1;HEUTE())

Die folgende Abbildung zeigt den Einsatz dieser Formel in einer Beispieltabelle:

Werden Sie mit unseren Tipps zum Excel-Profi!
Jetzt gratis per E-Mail

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter
  • + Excel-Praxistipps per Mail


Weitere Artikel zum Thema

Newsletter Excel-Praxistipps

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • jederzeit abbestellbar
  • + Excel-Praxistipps per Mail
DDV Qualitätsstandard E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.
Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"