Anzahl der Ziffern in einer Excel-Zelle bestimmen

27. Februar 2012
Martin Althaus Von Martin Althaus, Excel, Office ...

So stellen Sie mit einer Excel-Formel fest, wie viele Zahlen sich in einer Text-Zahlenkombination befinden

Mit dieser Matrixformel zählen Sie die Anzahl der Ziffern in einer Zelle

Mit dieser Matrixformel zählen Sie die Anzahl der Ziffern in einer Zelle

Artikelnummern, Zugriffscodes oder andere Daten werden gerne als Kombination aus Buchstaben und Zahlen aufgebaut. Dann stehen in Excel-Zellen Inhalte wie GR2343 oder 15-ZU-234.

Für die Analyse und das Auswerten solcher Daten kann es interessant sein, die Anzahl der Ziffern in einer solchen Text-Zahlenkombination zu zählen.

Für diese Aufgabe bietet Excel keine Standardfunktion an. Setzen Sie eine Matrixformel ein, in der die Funktionen SUMME, ISTZAHL, TEIL und SPALTE miteinander kombinieren. Wenn Sie die Ziffern in der Zelle A1 zählen wollen, sieht die Formel folgendermaßen aus:

=SUMME(ISTZAHL((TEIL(A1;SPALTE(1:1);1)*1))*1)

Bei dieser Formel handelt es sich um eine Matrixformel. Geben Sie die Formel daher über die Tastenkombination STRG UMSCHALT EINGABE ein. Mit der Taste UMSCHALT ist die Taste gemeint, die Sie gedrückt halten müssen, um eine Großbuchstaben einzugeben. Auch nach jeder Formeländerung verwenden Sie diese Tastenkombination.

Die folgende Abbildung zeigt den Einsatz der Matrixformel in einer Beispieltabelle:

Mit dieser Matrixformel zählen Sie die Anzahl der Ziffern in einer Zelle

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"