Bedingungen in Formeln verwenden

26. Mai 2010
Martin Althaus Von Martin Althaus, Excel, Office ...

So treffen Sie Wenn-Dann-Sonst-Entscheidungen per Formel

Wussten Sie, das für Excel der Wert WAHR der Zahl 1 entspricht und FALSCH der Zahl 0? Dass können Sie in der Praxis sehr gut gebrauchen, weil Sie so Bedingungen an Ihre Berechnungen knüpfen können.

In der folgenden Abbildung sehen Sie, wie das funktioniert. Sie zeigt eine Excel-Tabelle, in der Sie Bedingungen per Formel auswerten.

In Zelle A3 steht die folgende Formel:

=(A1=100)

Weil in Zelle A1 wirklich die Zahl 100 steht, zeigt Excel den Wert WAHR an. Dieser Wert entspricht der Zahl 1. Möchten Sie nun per Formel dafür sorgen, dass in Zelle A8 immer der Wert aus Zelle A6 eingetragen wird, wenn in Zelle A1 die Zahl 100 steht, können Sie das wie folgt formulieren:

=(A1=100)*A6

Wenn Sie Bedingung A1=100 wahr ist, löst dieser Ausdruck zur Zahl 1 auf und entsprechend ergibt sich als Resultat die Zahl aus A6 (A6 mit 1 multipliziert ergibt die Zahl aus A6).

Falls die Bedingung A1=100 nicht wahr ist, löst sich der Ausdruck zu einer 0 auf und die nachfolgende Multiplikation ergibt ebenfalls den Wert Null. Die folgende Abbildung zeigt, wie das in der Praxis funktioniert:

Die Abfrage können Sie auch über eine WENN-Funktion durchführen:

=WENN(A1=100;A6;0)

Der Vorteil beim direkten Einsatz der Bedingungen in einer Multiplikation besteht darin, dass Sie mehrere Bedingungen klar und deutlich miteinander kombinieren können. Multiplizieren Sie einfach alle Bedingungen miteinander, wenn alle Bedingungen erfüllt sein sollen.

Über die Methode können Sie auch die Grenze von maximal sieben Verschachtelungen aushebeln, auf die Funktionen in Excel bis Version 2007 beschränkt sind.

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"