Buchstaben oder Vorzeichen in Excel-Zellen austauschen oder umdrehen

30. April 2011
Martin Althaus Von Martin Althaus, Excel, Office ...

So holen Sie einen Text, einen Buchstaben oder ein Vorzeichen von hinten nach vorne

Die Vorzeichen stehen nun richtig

Die Vorzeichen stehen nun richtig

Wenn Sie Zahlen aus anderen Anwendungen oder Dateien in Excel importieren, kann es vorkommen, dass die Minuszeichen nicht vor, sondern hinter der Zahl stehen. Dann kann Excel mit den Zahlen nicht korrekt rechnen. Sie werden außerdem als Texte angesehen.

Die folgende Abbildung zeigt ein Beispiel für diese Situation:

Nur positive Werte in einer Zelle werden erkannt

In der Abbildung können Sie erkennen, dass Excel nur die positiven Werte direkt erkennt. Die negativen Werte mit nachfolgendem Minuszeichen werden als Texte angesehen.

Mit der folgenden Formel wandeln Sie solche Zahlen in Zahlen um, mit denen Excel rechnen kann:

=WENN(ISTZAHL(A2);A2;WERT("-"&WECHSELN(A2;"-";"")))

Die Formel wandelt den Wert in Zelle A2 in eine Zahl um. Sie können die Formel einfach über den gewünschten Bereich nach unten ziehen. Die folgende Abbildung zeigt, wie das Ergebnis aussieht:

Die Vorzeichen stehen nun richtig

Das Verfahren können Sie nicht nur für den Austausch von Vorzeichen einsetzen, auch Ziffern oder Buchstaben können Sie damit durch Zeichen Ihrer Wahl ersetzen.

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"