Daten flexibel mit Nachkommastellen darstellen

27. Oktober 2010
Martin Althaus Von Martin Althaus, Excel, Office ...

So zeigen Sie Kommastellen nach Wunsch an

Stellen Sie sich eine Tabelle vor, in der in der Spalte A importierte Daten stehen. Diese Zahlen haben unterschiedlich viele Nachkommastellen.

Die Werte sollen in Spalte B rechtsbündig mit so vielen Nachkommastellen dargestellt werden, wie maximal in der Spalte A vorkommen.

Die Funktion FEST oder ein benutzerdefiniertes Zahlenformat sind in diesem Fall nicht hilfreich, da immer gleich viele Nachkommastellen geliefert werden. Sie lösen die Aufgabenstellung mit einer Matrixformel, in der Sie die Funktionen WENN, FEST, REST, LÄNGE und FINDEN kombinieren. Das geht so:

In die erste Zeile der Spalte B tragen Sie die folgende Formel ein:

=WENN(A1="";"";FEST(A1;MAX(WENN(REST(A$1:A$1000;1)=0;0;LÄNGE(A$1:A$1000)-FINDEN(",";A$1:A$1000)))))

Die Eingabe der Formel bestätigen Sie mit der Tastenkombination STRG UMSCHALT EINGABE, da es sich um eine Matrixformel handelt. Mit UMSCHALT ist die Taste gemeint, die Sie kurz gemeinsam mit einer anderen Taste drücken müssen, um einen Großbuchstaben zu erhalten.

Anschließend formatieren Sie die Zelle rechtsbündig. Die Formel kopieren Sie dann in die Zwischenablage und fügen sie in die darunter liegenden Zellen der Spalte B ein. Die folgende Abbildung zeigt die Formel in der Praxis:

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"