Datenreihenfolge abhängig von Farben gestalten

03. November 2010
Martin Althaus Von Martin Althaus, Excel, Office ...

Wie Sie Farben als Sortierkriterium verwenden

In einer Liste werden Angebote erfasst. Die Preise sind mit einer bedingten Formatierung nach Grenzwerten mit einem farbigen Zellhintergrund versehen. Im Beispiel werden alle Preise unter 150 Euro grün, die zwischen 150 und 220 Euro gelb und die darüber rot markiert. Die folgende Abbildung zeigt einen Auszug aus der Liste:

Die Liste soll nun so sortiert werden, dass die Zeilen mit grün hinterlegten Preisen oben stehen. Dann folgen die gelben und ganz unten stehen die rot markierten Werte.

Bei der Arbeit mit Excel 2007 ist diese Aufgabenstellung recht einfach zu bewältigen, da diese erstmals das Filtern und Sortieren nach Farben ermöglicht.

Wenn Sie eine der früheren Versionen von Excel einsetzen, ist die Sortierung nach Farben ein wenig aufwändiger, da sie in den Bordmitteln noch nicht vorgesehen war. So erreichen Sie dennoch Ihr Ziel:

Legen Sie in Ihrer Tabelle eine Hilfsspalte neben den Preisen an, im vorliegenden Beispiel in der Spalte C. In dieser müssen Sie mit einer WENN-Abfrage den Zellhintergrund der Zellen der Spalte B ermitteln und in die Spalte B die Farbe eintragen. Vor den Farbnamen setzen Sie eine Zahl, die bei der späteren Sortierung die Reihenfolge vorgibt. Im vorliegenden Beispiel gelten die folgenden Grenzen und Farbnamen für die Hilfsspalte:

<150               1Grün
>150<220       2Gelb
>220               3Rot

Für die Abfrage tragen Sie die folgende Formel in die Zelle C2 ein:

=WENN(B2>220;"3Rot";WENN(B2>150;"2Gelb";"1Grün"))

Diese Formel kopieren Sie in der Spalte C nach unten. In den Zellen erscheinen daraufhin die Farbnamen der Spalte B.

Diese Spalte setzen Sie zur Sortierung ein. Durch die Verwendung der Ziffer vor dem Farbnamen erhalten Sie dadurch eine Sortierung nach Farben.

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"