Datensätze mit bestimmten Zusätzen gezielt per Excel-Formel markieren

08. September 2011
Martin Althaus Von Martin Althaus, Excel, Office ...

Suchen Sie über eine Excel-Formel gezielt nach bestimmten Textbestandteilen in Ihren Daten und machen Sie diese Daten in Ihrer Liste erkennbar

Abfrage nach mehreren Gesellschaftsformen

Abfrage nach mehreren Gesellschaftsformen

In einer Liste in einer Excel-Tabelle werden Namen erfasst. Bei einigen handelt es sich um Privatpersonen, andere tragen einen Firmenzusatz. Die folgende Abbildung zeigt einen Ausschnitt aus der Beispieltabelle:

Namen in einer Excel-Liste

In dieser Liste sollen die Einträge in der Spalte B mit der Ziffer 1 markiert werden, die den Zusatz "GmbH" tragen.

Zur Lösung dieser Aufgabe tragen Sie die folgende Formel in die Zelle B3 ein:

=WENN(ISTFEHLER(FINDEN("GmbH";A3));"";1)

Basis dieser Formel ist die Funktion FINDEN. Damit können Sie in einem Text in einer Zelle nach einem bestimmten Text suchen. Als Ergebnis liefert die Funktion die Position des ersten Zeichens des gesuchten Textes in der Zelle.

Wenn der Text nicht gefunden wird, erhalten Sie den Fehler #Wert!. Das machen Sie sich hier zunutze, indem Sie mit der WENN-Abfrage überprüfen, ob ein Fehler geliefert wird.

Wenn das so ist, ist der Text "GmbH" nicht in der Zelle enthalten. Dann geben Sie mit der WENN-Abfrage eine leere Zelle zurück. Wenn FINDEN einen beliebigen Wert liefert, ist der Text enthalten und die Abfrage trägt die Zahl 1 in die Zelle ein.

Wichtig: Obwohl die Funktion SUCHEN der Funktion FINDEN sehr ähnlich ist, sollten Sie sie für diese Aufgabenstellung nicht verwenden. Sie unterscheidet nämlich nicht nach Groß- und Kleinschreibung, was schnell zu Fehlern führen kann. Das ist bei "GmbH" noch kein großes Problem, kann sich zum Beispiel bei der Suche nach "AG" negativ auswirken.

Die Formel in der Zelle B3 kopieren Sie für die weiteren Zeilen Ihrer Liste in der Spalte B ausreichend weit nach unten. In allen Zeilen, die in der Spalte B den Zusatz "GmbH" tragen, erscheint dann die Ziffer 1.

Beachten Sie, dass die Formel nicht nur "GmbH" als Zusatz hinter dem Namen erkennt, sondern an jeder beliebigen Position. Damit deckt diese Abfrage auch Erweiterungen wie "GmbH & Co. KG" mit ab.

Die nachfolgende Abbildung zeigt den Einsatz der Formel in einer Beispieltabelle:

Abfrage nach dem Zusatz "GmbH" per Excel-Formel

Wenn Sie nicht nur die GmbH, sondern auch andere Gesellschaftsformen berücksichtigen möchten, müssen Sie die Abfrage um eine UND-Funktion erweitern, in der Sie die einzelnen Texte angeben.

Die folgende Formel beispielweise gibt den Wert 1 zurück, wenn die Zusätze "GmbH", "AG" oder "GbR" enthalten sind:

=WENN(UND(ISTFEHLER(FINDEN("GmbH";A3));ISTFEHLER(FINDEN("AG";A3));ISTFEHLER(FINDEN("GbR";A3)));"";1)

Auch diese Formel kopieren Sie in der Spalte ausreichend weit nach unten. Die folgende Abbildung zeigt das Ergebnis:

Abfrage nach mehreren Gesellschaftsformen

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"