Die Sieger beim Excel-Formelwettbewerb

06. November 2008
Martin Althaus Von Martin Althaus, Excel, Office ...

Zwei Formeln teilen sich Platz 1

Liebe Leserin, lieber Leser,

seit heute ist der zweite Excel-Formelwettbewerb beendet. Ich danke allen, die mitgemacht und mitdiskutiert haben, ganz herzlich! Es hat viel Spaß gemacht, die Diskussionen und Lösungen zu verfolgen.

Es hat sich aber auch gezeigt, dass auch die scheinbar klare Aufgabenstellung zig verschiedene Fragestellungen aufwirft und Dutzende von Lösungsansätzen bietet.

Der Sieger steht aber dennoch fest, zumindest aus meiner Sicht. Die kürzeste Formel hat 49 Zeichen:

=WENN(ANZAHL(FINDEN(ZEILE(A:A)-1;A1));"ja";"nein")

=WENN(ANZAHL(1*TEIL(A1;ZEILE(A:A);1));"ja";"nein")

Sie sehen: es gibt zwei Sieger! Die erste Formel stammt in der ersten Grundversion von Andreas Lohnecke und wurde von Roger Friebus, Bernd Kohlen und Thomas A. ergänzt und verbessert. Die zweite Formel hat Peter Meindl entwickelt.

Es handelt sich in beiden Fällen um Matrixformeln, die ich Ihnen in dieser Ausgabe von ExcelDaily weiter unten genauer vorstelle.

Als Kriterien für die Siegerformel war deutlich benannt, dass die kürzeste Formel prämiert werden soll. Und zwar die kürzeste Formel, die "als Ergebnis" den Wert "ja" oder "nein" liefert. Daher fällt die sehr clevere Formelvariante von Thomas Wagner aus der Wertung. Sie funktioniert nur mit einem benutzerdefinierten Zahlenformat in der Ergebniszelle.

Demzufolge kann man mit dem Formelergebnis "ja" und "nein" auch nicht in anderen Formeln direkt weiterrechnen, weil es ja nur angezeigt wird, aber nicht als Ergebnis in der Zelle steht.

Neben der Siegerformel gibt es noch weitere sehr pfiffige Varianten. Und wie viele von Ihnen in der Diskussion auf excellent.exceldaily.de geäußert haben, ist die kürzeste Formel nicht immer die beste. Oder wie Peter Meindl es formuliert: "Der Weg ist das Ziel! Für mich dient der Wettbewerb dazu, Excel besser kennenzulernen. Die beste Formel in diesem Sinne ist jene, zu der der längste und informativste Forum-Thread geführt hat!" Peter hat es auf den Punkt gebracht!

Vor allem aus Geschwindigkeitsgründen bietet es sich an, manchmal nicht die kürzeste Varianten einer Formel zu wählen. Auch die Lesbarkeit von Formeln leidet meist unter einer starken Verkürzung, weil sie durch starke Reduzierung immer komplexer werden.

Daher lohnt es sich in jedem Fall, noch einmal in die Ergebnisse des Formel-Wettbewerbs hineinzuschauen. Verwenden Sie den folgenden Link:

http://excellent.mixxt.de/networks/forum/thread.4553

Ich möchte mich bei allen Diskussionsteilnehmern für das Engagement bedanken!

Und ich bin sicher: Es wird bald die nächste Staffel des Formel-Wettbewerbs geben. Für den nächsten Formelwettbewerb wäre ein Wettstreit interessant, der einmal die schnellste Formel für eine bestimmte Aufgabe ausschreibt.

Ich weiß nur noch nicht genau, wie wir die Formelgeschwindigkeiten objektiv und einheitlich messbar machen können. Das muss ja auch so geschehen, dass es ein jeder auf seinem PC nachvollziehen kann. Ich zerbreche mir schon den Kopf, wie wir das lösen können. Vielleicht haben Sie eine Idee?

Mit freundlichem Gruß

Ihr

Martin Althaus, Chefredakteur von Excel Daily

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"