Excel-Formel: Minuszeichen von rechts nach links stellen

15. Februar 2008
Martin Althaus Von Martin Althaus, Excel, Office ...

So räumen Sie importierte Zahlen blitzschnell auf

Beim Import von Daten in eine Tabelle kann es sein, daß bei negativen Zahlen das Minuszeichen nicht – wie üblich – links, sondern rechts der Zahl steht.

Das ist zum Beispiel bei einigen Datenbanken oder bei Zahlenformaten bestimmter Länder der Fall. Excel ist nicht in der Lage, derartige Zahlen als negative Werte zu interpretieren.

Wenn Sie damit rechnen möchten, müssen Sie also das Minuszeichen nach links stellen. Bei dieser Aufgabe hilft Ihnen eine Formel, in der die Funktionen WENN, RECHTS, TEIL und LÄNGE miteinander kombiniert werden.

Die Umstellung erledigen Sie am besten in einer neuen Spalte, die Sie rechts der umzuwandelnden anlegen. Wenn die umzuwandelnde Zahl in der Zelle A1 steht, tragen Sie in die Zelle B1 die folgende Formel ein:

=WENN(RECHTS(A1;1)="-";TEIL(A1;1;LÄNGE(A1)-1)*-1;A1)

Füllen Sie die Formel in der neuen Spalte nach unten aus, um alle Zahlen umzuwandeln. Falls Sie die umgewandelten Zahlen nun als neue Zahlen an der ursprünglichen Position einfügen möchten, gehen Sie folgendermaßen vor:

     

  1. Markieren Sie den Zellbereich mit den neuen, richtigen Vorzeichen.
  2. Kopieren Sie den Bereich über die Funktion "Bearbeiten – Kopieren".
  3. Markieren Sie den ursprünglichen Zellbereich mit den Vorzeichen an der falschen Position.
  4. Rufen Sie die Funktion "Bearbeiten – Inhalte einfügen" auf und klicken Sie die Option "Werte" an, drücken Sie dann die OK-Schaltfläche.
  5.  

Anschließend können Sie die zusätzlich eingerichtete Spalte wieder löschen.

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"