Excel-Formelerweiterung gezielt steuern

28. Oktober 2008
Martin Althaus Von Martin Althaus, Excel, Office ...

So verhindern Sie die automatische Formelanpassung in Ihren Listen

Für Verwirrung sorgt bei vielen Excel-Anwendern die automatische Veränderung von Formeln in Excel-Listen. Stellen Sie sich eine Tabelle vor, in der in der Zelle H1 beispielsweise die Formel =SUMME(A1:F1) steht.

Wenn Sie nun in Zelle G1 einen Wert eingeben, wird die Formel automatisch angepasst. In der Zelle H1 steht dann =SUMME(A1:G1):

Die beschriebene Anpassung tritt auch in senkrechter Form auf. Wenn also Werte in den Zeilen 1 bis 6 stehen und Sie die Formel =SUMME(A1:A6) in Zelle A8 anwenden, wird sich diese Formel anpassen, sobald Sie einen Wert in Zelle A7 schreiben. Die folgende Abbildung zeigt die angepasste Formel für das oben beschriebene Beispiel:

Hinter dem oben beschriebenen Phänomen verbirgt sich kein Fehler, sondern ein Feature, das Ihnen Excel zur Verfügung stellt. Excel will Sie damit unterstützen, denkt sozusagen mit und passt die Bezüge logisch an. Wenn Ihnen diese Art der Einmischung von Excel in Ihre Kalkulationen missfällt, haben Sie zwei Möglichkeiten:

Wenn Sie die Anpassung lediglich für diesen einen speziellen Fall verhindern wollen, geben Sie den Bezug in der Summen-Formel absolut an. Die Formel lautet dann zum Beispiel:

=SUMME(A1:$F1)

Falls Sie die automatische Anpassung der Bezüge durch Excel grundsätzlich für alle Formeln unterbinden wollen, gehen Sie folgendermaßen vor:

  1. Rufen Sie im Menü "Extras" den Befehl "Optionen" auf.
  2. In der erscheinenden Dialogbox aktivieren Sie das in der folgenden Abbildung dargestellte Register "Bearbeiten":


     
  3. Die in diesem Register zu deaktivierende Option heißt je nach Excel-Version "Datenbereich und Formeln erweitern" (Excel 2003) oder "Listenformat und Formeln erweitern" (Excel XP und Excel 2000).
  4. Bestätigen Sie Ihre Einstellung mit "OK".

Nach dieser Änderung werden Formeln nur dann noch erweitert, wenn Sie das ausdrücklich wünschen.

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"