Excel Matrixformel: Einträge mit einer bestimmten Zeichenfolge zählen

18. März 2008
Martin Althaus Von Martin Althaus, Excel, Office ...

So zählen Sie gesuchte Einträge in Ihren Listen mit einer Matrixformel

Sie möchten in Ihren Listen das Auftreten bestimmter Zahlenfolgen zählen?

Über eine Matrixformel überprüfen Sie einen Zellbereich und zählen die Zellen, in denen eine bestimmte Zeichenkette vorkommt. Die Matrixformel ist folgendermaßen aufgebaut:

=SUMME(WENN(TEIL(Bereich;Anfang;Ende)="Zeichenkette" ;1;0))

Bereich legt die Zellen fest, die Sie überprüfen möchten.

Mit Anfang und Ende bestimmen Sie, an welcher Position sich die Zeichenkette befinden soll.

Mit der folgenden Eingabe zählen Sie zum Beispiel wie viele Zellen im Bereich A1:A10 mit der Zeichenkette "123" beginnen:

=SUMME(WENN(TEIL(A1:A10;1;3)="123" ;1;0))

Beachten Sie bei der Eingabe der Formel, daß es sich um eine Matrixformel handelt. Matrixformeln erkennen Sie an den geschweiften Klammern, mit denen Excel sie automatisch einrahmt.

Exceltabelle Summe

Im Gegensatz zu den normalen Formeln, die nur mit der Taste EINGABE beendet werden, schließen Sie Matrix-Formeln mit STRG UMSCHALT EINGABE ab. Hinweis: mit UMSCHALT ist die Taste gemeint, die Sie gemeinsam mit einer Buchstabentaste drücken müssen, um einen Großbuchstaben zu erzeugen.

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"