Fehlerwerte in Excel-Berechnungen unterdrücken

12. Mai 2011
Martin Althaus Von Martin Althaus, Excel, Office ...

So sorgen Sie dafür, dass auch leere Zellen nicht zu Fehlermeldungen in Ihren Excel-Berechnungen führen

Fehlerfreie Wenn-Abfrage mit ISTLEER

Fehlerfreie Wenn-Abfrage mit ISTLEER

Wie können Sie Fehlerwerte in Tabellen unterdrücken, die allein darauf beruhen, dass in einer Zelle noch keine Werte stehen?

Denken Sie beispielsweise an die Division der Zellen A2 und B2 mit der Formel =A2/B2.

Solange in der Zelle B2 noch kein Wert steht, liefert die Formel den Fehlerwert #DIV/0!:

Eine Fehlermeldung in der Excel-Tabelle

Eine Lösung für diesen „Schönheitsfehler“ ist eine WENN-Abfrage, in der überprüft wird, ob die Formel einen Fehler liefert. Die Abfrage sieht folgendermaßen aus:

=WENN(ISTFEHLER(A2/B2);"";A2/B2)

In der Beispieltabelle sieht das so aus:

WENN-Abfrage mit ISTFEHLER

Diese Methode der WENN-Abfrage hat den Nachteil, dass die eigentliche Formel immer zwei Mal eingetragen werden muss. Das kann bei komplexeren Formeln lästig und fehleranfällig sein. Es geht aber auch komfortabler.

Im Beispiel können Sie eine Abfrage einrichten, die überprüft, ob die Zelle B2 leer ist. Dann wird eine leere Zelle ausgegeben, ansonsten wird gerechnet. Die eigentliche Formel muss dann nur einmal eingegeben werden. Die Abfrageformel sieht folgendermaßen aus:

=WENN(ISTLEER(B2);"";A2/B2)

Die folgende Abbildung zeigt den Einsatz der Formel in der Beispieltabelle:

Fehlerfreie Wenn-Abfrage mit ISTLEER

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"