Fehlerwerte in Excel-Formeln unterdrücken

19. März 2009
Martin Althaus Von Martin Althaus, Excel, Office ...

Wie Sie Fehler in Ihren Formeln abfangen

Fehlerwerte in Excel-Tabellen beruhen häufig darauf, dass in einer Zelle noch keine Werte stehen.

Denken Sie beispielsweise an die Division der Zellen A1 und B1 mit der folgenden Formel

=A1/B1.

Solange in der Zelle B1 noch kein Wert steht, liefert die Formel den Fehlerwert #DIV/0!.

Eine einfache Lösung für einen solchen "Schönheitsfehler" ist eine Wenn-Abfrage, in der überprüft wird, ob die Formel einen Fehler liefert. Die Abfrage sieht folgendermaßen aus:

=WENN(ISTFEHLER(A1/B1);"";A1/B1)

Excel rechnet die Formel nur dann aus, wenn die Formel selbst keinen Fehler ergibt. Ansonsten wird ein leerer Text als Ergebnis angezeigt.

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"