Fehlerwerte unsichtbar machen

16. April 2009
Martin Althaus Von Martin Althaus, Excel, Office ...

Wie Sie Fehlerwerte in Excel per bedingter Formatierung unterdrücken

Sie suchen nach einer Lösung suchen, mit der sie Fehlerwerte in Tabellen unterdrücken können, die darauf beruhen, dass in einer Zelle noch keine Werte stehen?

Denken Sie beispielsweise an die Division der Zellen A2 und B2 mit der Formel =A2/B2.

Solange in der Zelle B2 noch kein Wert steht, liefert die Formel den Fehlerwert #DIV/0!.

Eine weitverbreitete Lösung für diesen "Schönheitsfehler" ist eine Wenn-Abfrage, in der überprüft wird, ob die Formel einen Fehler liefert. Die Abfrage sieht folgendermaßen aus:

=WENN(ISTFEHLER(A2/B2);"";A2/B2)

Diese Methode der Wenn-Abfrage hat den Nachteil, dass die eigentliche Formel immer zwei Mal eingetragen werden muss. Das kann bei komplexeren Formeln lästig und fehleranfällig sein. Es geht aber auch komfortabler:

Einen Weg bietet Ihnen die bedingte Formatierung. Diese hat den Vorteil, dass Sie in die Zelle lediglich die eigentliche Formel eingeben müssen.

Dann markieren Sie die Ergebniszelle und rufen im Menü "Format" den Befehl "Bedingte Formatierung" auf. In der erscheinenden Dialogbox wählen Sie im linken Listfeld den Eintrag "Formel ist".

In das Eingabefeld geben Sie die folgende Formel ein:

=ISTFEHLER(Ergebniszelle)

Für Ergebniszelle tragen Sie die Adresse der Zelle mit der Divisionsformel ein, beispielsweise B7.

Dann klicken Sie auf die Schaltfläche "Format" und stellen auf der Registerkarte "Schrift" die Farbe des Tabellenhintergrunds ein – in der Regel Weiß. Dies bestätigen Sie mit "OK".

Die Dialogbox sieht daraufhin folgendermaßen aus:

Nach dem Bestätigen mit "OK" steht der Fehlerwert noch in der Zelle, ist aber nicht mehr zu sehen.

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"