Funktionsassistenten von Excel per VBA-Makro mit einer Funktion Ihrer Wahl aufrufen

19. Oktober 2011
Martin Althaus Von Martin Althaus, Excel, Office ...

So starten Sie den Funktions-Assistenten von Excel aus einem VBA-Makro

Der Funktions-Assistent schlägt die Funktion SUMME mit dem Datenbereich A1:A9 vor

Der Funktions-Assistent schlägt die Funktion SUMME mit dem Datenbereich A1:A9 vor

Wussten Sie, dass Sie den Funktionsassistenten auch per VBA aufrufen und damit Anwendern einer Excel-Lösung bestimmte Tabellenfunktionen vorschlagen können?

Stellen Sie sich vor, Sie möchten die Formel =SUMME(A1:A9) in Zelle A10 der aktiven Tabelle eintragen. Die Funktion soll über den Funktions-Assistenten vorgeschlagen werden, so dass der Anwender sie nur noch bestätigen (oder ändern) muss. Setzen Sie das folgende VBA-Makro ein:

Sub RufeFunktionAuf()
ActiveSheet.Range("a10").Select
ActiveCell.FormulaLocal = "=summe(A1:A9)"
Application.Dialogs(xlDialogFunctionWizard).Show
End Sub

Um das Makro einzugeben, drücken Sie in Excel die Tastenkombination ALT F11. Damit rufen Sie den VBA-Editor auf. Fügen Sie hier über das Kommando EINFÜGEN - MODUL ein leeres Modulblatt ein. Um das Makro zu starten, drücken Sie innerhalb von Excel die Tastenkombination ALT F8.

Nach dem Start des Makros zeigt Excel das Fenster des Funktions-Assistenten an. In diesem Fenster ist die Funktion SUMME bereits voreingestellt. Der Anwender kann bei Bedarf den Wertebereich der Funktion verändern. Die folgende Abbildung zeigt, wie das Fenster in der Praxis aussieht:

Der Funktions-Assistent schlägt die Funktion SUMME mit dem Datenbereich A1:A9 vor

Durch einen Klick auf OK wird die Voreinstellung der Funktion übernommen.

Um das Makro anzupassen, legen Sie in der Wertzuweisung an die Eigenschaft FORMULALOCAL den Namen der Funktion fest, die Sie in die Zelle eintragen möchten. Verwenden Sie die Namen der Tabellenfunktionen, wie Sie sie aus der interaktiven Arbeit mit Excel kennen. Achten Sie darauf, vpor dem Funktionsnamen ein Gleichheitszeichen zu platzieren.

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"