Inhalte finden und überprüfen

04. August 2009
Martin Althaus Von Martin Althaus, Excel, Office ...

Wie Sie Werte schnell und zuverlässig finden

Das Suchen von Inhalten in Listen ist sehr zeitaufwändig und mühsam. Über den Menübefehl "Bearbeiten – Suchen" nimmt Ihnen Excel diese lästige Aufgabe ab. Falls Sie aber nur wissen müssen, ob und nicht wo ein bestimmter Inhalt in einer Tabelle oder Liste auftritt, können Sie eine Matrixformel einsetzen, um diese Aufgabe zu lösen.

Die Suche geht dann schneller und effektiver. Außer der Matrixformel benötigen Sie noch eine Zelle, in die Sie den Suchbegriff eintragen.

Die Matrixformel mit der Sie das Auftreten eines Inhalts in einem Bereich prüfen, sieht so aus:

=WENN(ODER(IDENTISCH(Bereich;Suchbegriff));"ja";"nein")

Mit "Bereich" übergeben Sie den Zellbereich, in dem Sie suchen möchten. Mit "Suchbegriff" übergeben Sie den Bezug auf die Zelle, in die Sie den jeweils zu ermittelnden Begriff eintragen. Falls der Suchbegriff im übergebenen Bereich auftritt, liefert die Formel als Ergebnis den Wahrheitswert WAHR. Stimmt keine Zelle aus "Bereich" exakt mit Ihrem Suchbegriff überein, wird als Ergebnis der Wahrheitswert FALSCH geliefert.

Die folgende Abbildung zeigt ein Beispiel für den Einsatz Ihrer Formel:

In Zelle B12 der abgebildeten Tabelle wird die folgende Formel verwendet:

=WENN(ODER(IDENTISCH(A3:A9;B11));"ja";"nein")

Denken Sie daran, die Formel nach der Eingabe über die Tastenkombination STRG-SHIFT-ENTER zu bestätigen, da es sich um eine Matrixformel handelt.

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"