Inhaltsänderung per Formel erkennen

26. Juli 2010
Martin Althaus Von Martin Althaus, Excel, Office ...

Wie Sie Buchstabenwechsel in einer Spalte markieren

In einer umfangreichen Adressliste soll in der ersten Spalte immer der Anfangsbuchstabe erscheinen, wenn in der sortierten Liste in der zweiten Spalte ein neuer Anfangsbuchstabe steht.

Diese Aufgabenstellung lösen Sie durch die Kombination verschiedener Textfunktionen. Angenommen, die Liste steht in der Spalte B, wobei die erste Zeile den Spaltentitel "Name" enthält. In der Spalte A sollen nun die Buchstabenwechsel markiert werden. Tragen Sie dazu in die Zelle A2 die folgende Formel ein:

=GROSS(LINKS(B2;1))

Diese Formel liefert das erste Zeichen des Zellinhalts der Zelle B2 als Großbuchstabe. Die folgende Abbildung zeigt das Ergebnis der Formel in der Beispieltabelle:

Für die Überprüfung, ob in der Spalte B ein neuer Anfangsbuchstabe steht, verwenden Sie eine Wenn-Abfrage. Tragen Sie dazu die folgende Formel in die Zelle A3 ein:

=WENN(LINKS(B3;1)<>LINKS(B2;1);GROSS(LINKS(B3;1));"")

Diese Formel überprüft, ob der erste Buchstabe in B3 ein anderer ist als in der Zelle B2. Wenn ja, wird dieser ausgegeben, ansonsten eine leere Zelle. Die folgende Abbildung zeigt den Einsatz der Formel in der Beispieltabelle:

Für die Überprüfung der weiteren Zeilen müssen Sie die Formel aus der Zelle A3 ausreichend weit nach unten kopieren. Durch die automatische Anpassung der relativen Bezüge wird immer die aktuelle Zeile mit der Zeile darüber verglichen. Die folgende Abbildung zeigt die fertige Tabelle, in der die Buchstabenwechsel immer durch den neuen Anfangsbuchstaben angezeigt werden:

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"