Mit ISTNV beim SVERWEIS eine #NV-Meldung unterdrücken

01. August 2017
Martin Althaus Von Martin Althaus, Excel, Office ...

Kommt Ihnen als geübtem Excel-Anwender das auch bekannt vor? Beim SVERWEIS erhalten Sie bei exakter Suche – wenn in der Suchmatrix der Wert nicht vorhanden ist – als Ergebnis #NV für „no value“ oder „nicht vorhanden“. Dieses Schönheitsproblem lösen Sie, indem Sie eine WENN-Funktion um eine IST-Funktion – hier ISTFEHLER oder ISTNV – legen.

So bauen Sie die Formel auf:

  • Markieren Sie die Zelle E5.
  • Geben Sie in die Bearbeitungszeile =WENN( ein.
  • Prüfen Sie nun zuerst, ob das Ergebnis des SVERWEIS den Fehlerwert #NV liefert. Tragen Sie dazu direkt hinter der Klammer folgende Formel ein:
    ISTNV(SVERWEIS($C$5;$B$10:$E$14;2;FALSCH))
  • Geben Sie ein Semikolon ein und geben Sie für den Dann-Wert der WENN-Funktion zwei Anführungszeichen direkt hintereinander ein. Somit wird der Fehlerwert #NV durch eine leere Zelleingabe ersetzt, sobald der Wert in der Suchmatrix nicht vorhanden ist.
  • Geben Sie ein weiteres Semikolon ein und tragen Sie für den Sonst-Wert der WENN-Funktion erneut den SVERWEIS ein. Dieser holt nun aus der Matrix die gesuchte Bezeichnung.

Ihre komplette Formel müsste nun wie folgt aussehen:

=WENN(ISTNV(SVERWEIS($C$5;$B$10:$E$14;2;FALSCH));"";
SVERWEIS($C$5;$B$10:$E$14;2;FALSCH))

Seit Excel 2013 geht es auch mit WENNNV

Seit Excel 2013 gibt es eine neue Funktion WENNNV, die die gerade beschriebene Fehlermeldung schneller und eleganter löst:

  • Markieren Sie Zelle E5.
  • Geben Sie in die Bearbeitungszeile =WENNNV( ein.
  • Tragen Sie hinter der Klammer den SVERWEIS wie folgt ein: (SVERWEIS($C$5;$B$10:$E$14;2;FALSCH)
  • Geben Sie ein Semikolon ein und tragen Sie als zweites Argument für die Funktion WENNNV den Wert ein, der ausgegeben werden soll, wenn der SVERWEIS den Rückgabewert #NV liefert. Geben Sie wie eben einfach zwei Anführungszeichen direkt hintereinander ein.

Ihre komplette Formel müsste nun wie folgt aussehen:

=WENNNV(SVERWEIS($C$5;$B$10:$E$14;2;FALSCH);"")

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"