Jede zweite Zeile in einem Mittelwert berücksichtigen

26. November 2010
Martin Althaus Von Martin Althaus, Excel, Office ...

So bilden Sie Mittelwerte nicht für jede Zeile

Stehen überflüssige Inhalte zwischen Werten, aus denen Sie einen Mittelwert bestimmen möchten, wird die Addition kompliziert. Eine Formel kann Ihnen helfen.

Stellen Sie sich vor, Sie möchten aus den Zahlen im Bereich A1:A1000 den Mittelwert bilden, aber dabei nur die Zellen mit geraden Zeilennummern berücksichtigen, also A2, A4 usw. Verwenden Sie dazu die folgende Formel:

=MITTELWERT(WENN(REST(ZEILE(A1:A1000);2)=0;WENN(ISTLEER(A1:A1000);"";A1:A1000);""))

Damit die Formel funktioniert, müssen Sie sie über die Tastenkombination STRG UMSCHALT EINGABE eingeben (mit UMSCHALT ist die Taste gemeint, die Sie gedrückt halten müssen, um einen Großbuchstaben zu erreichen, diese Taste wird auch SHIFT genannt). Dann stellt Excel die Formel in geschweiften Klammern dar.

Auch nach einer Änderung der Formel müssen Sie immer diese Tastenkombination verwenden, um die Formel einzugeben.

Falls Sie anstelle der geraden nur die ungeraden Zeilennummern addieren möchten, verwenden Sie die folgende Formel:

=MITTELWERT(WENN(REST(ZEILE(A1:A1000);2)=1;WENN(ISTLEER(A1:A1000);"";A1:A1000);""))

Über die ZEILE-Funktion wird die Nummer der Zeile ermittelt. Über REST wird geprüft, welchen Rest diese Zeilennummer bildet, wenn man sie durch 2 teilt. Ist der Rest 0, ist es eine gerade Zeilennummer, ist der Rest 1, handelt es sich um eine ungerade Zeilennummer.

Diese Bedingung wird über eine WENN-Funktion überprüft. Fällt sie positiv aus, kann der Inhalt grundsätzlich für den Mittelwert berücksichtigt werden. Das gilt aber nur, wenn die Zelle nicht leer ist. Diese Abfrage folgt in der eingeschachtelten WENN-Funktion. Falls die Zelle nicht leer ist, wird der entsprechende Zellinhalt beim Mittelwert berücksichtigt, ansonsten wird ein leerer Text an die Funktion MITTELWERT übergeben. Diese Konstruktion ist nötig, damit der Mittelwert bei leeren Zellen nicht durch die dazugehörigen Nullwerte verfälscht wird.

Durch die Matrixformel sorgt das Kommando dafür, dass die Operation für alle Zellen im Bereich A1:A1000 der Reihe nach durchgeführt wird. Die folgende Abbildung zeigt den Einsatz beider Formeln in der Praxis:

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"