Kategorien per Formel verteilen

12. Mai 2010
Martin Althaus Von Martin Althaus, Excel, Office ...

Wie Sie Zahlen einsortieren

Ob es nun die Einteilung von Produktgruppen, das Zuordnen von Testergebnissen oder andere Aufgaben sind: Oft geht es darum, Zahlen in einem bestimmten Wertebereich einem Buchstaben oder einem Prädikat zuzuordnen.

Wie machen Sie das per Formel besonders pfiffig? Stellen Sie sich die Vorschrift vor, die in der folgenden Abbildung dargestellt ist:

In Zelle B1 tragen Sie eine Zahl ein. In Zelle B2 soll dazu ein passender Buchstabe ausgegeben werden. zu welcher Zahl, welcher Buchstabe gehört, zeigt die Zuordnung ab Zeile 5: Bei Werten von 1 bis 9 soll der Buchstabe A ausgegeben werden, bei Werten von 10 bis 19 der Buchstabe B und bei Werten ab 20 der Buchstabe C.

Sie können diese Aufgabe in einer einzigen Formel lösen, die ganz ohne WENN-Abfragen oder anderes auskommt. Das hat den Vorteil, dass Sie anstelle von drei Zuordnungskriterien auch viel mehr Kriterien einsetzen können. Die passende Formel lautet:

=SVERWEIS(B1;{1."A";10."B";20."C"};2)

In der Formel wird eine Matrix eingesetzt. Sie müssen die geschweiften Klammern in der Formel mit eingeben und die Formel wie gewohnt über die Taste EINGABE (ENTER) eingeben.

Innerhalb der geschweiften Klammern ist die Zuordnung der Werte zu den passenden Buchstaben untergebracht. Dabei setzt die Formel Wertepaare ein, die jeweils durch einen Punkt getrennt werden. Die Matrix {1."A";10."B";20."C"} lesen Sie wie folgt: "Ab 1 zeige A, ab 10 zeige B, ab 20 zeige C".

Für Ihre Aufgaben können Sie diese Matrix problemlos anpassen oder vergrößern. Natürlich ist es auch möglich, anstelle von einzelnen Buchstaben Zeichenketten oder Zahlen als Ergebnis auszugeben. Passen Sie dazu einfach die Buchstaben in der Formel an.

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"