Kriterien bei der Mittelwertberechnung berücksichtigen

13. September 2016
Martin Althaus Von Martin Althaus, Excel, Office ...

Bei der Berechnung des Mittelwerts über die MITTELWERT-Funktion können Sie keine Bedingungen festlegen. Das heißt, Sie können nicht definieren, welche Daten einer Liste in die Berechnung des Mittelwerts einfließen sollen.

So sieht die Formel aus, die Sie für die Berechnung eines Mittelwertes mit zwei Bedingungen benötigen:

=MITTELWERT(WENN(Bereich1=Bedingung1; Werte;““);WENN(Bereich1<>Bedingung1; WENN(Bereich2=Bedingung2;Werte;““)))

Sie übergeben der Matrixformel insgesamt fünf Argumente, um die Mittelwertberechnung durchzuführen:

 

  • Mit Bereich1 und Bereich2 übergeben Sie die beiden Bereiche, in denen Sie auf die Bedingungen prüfen möchten.
  • Die beiden Argumente Bedingung1 und Bedingung2 definieren die Bedingungen auf die Sie in den beiden Bereichen prüfen möchten.
  • Als fünftes Argument übergeben Sie mit Werte den Bereich, in dem die Werte aufgeführt sind, von denen Sie den Mittelwert berechnen möchten.

Als Ergebnis liefert die Formel den Mittelwert derjenigen Werte, bei denen mindestens eine der beiden Bedingungen erfüllt ist.

Bestätigen Sie die Formel nach der Eingabe über die Tastenkombination Strg+Umschalt+Eingabe, da es sich um eine Matrixformel handelt.

Im abgebildeten Arbeitsblatt berechnen Sie in Zelle B5 den Mittelwert der Liste anhand der darüberliegenden Bedingungen. Dazu verwenden Sie die folgende Matrixformel:

=MITTELWERT(WENN(A8:A19=B3;C8:C19;““);
WENN(A8:A19<>B3;WENN(B8:B19=B4;C8:C19;““)))

So funktioniert die Berechnung des Mittelwerts mit zwei Oder-Bedingungen

Über diese Kombination aus Tabellenfunktionen kommt die Formel zu dem gewünschten Ergebnis:

  • Über die erste WENN-Funktion prüfen Sie, ob der Bereich A8:A19 mit B3 übereinstimmt.
  • Wenn das zutrifft ist, wird der dazugehörige Inhalt des Bereichs C8:C19 an die MITTELWERT-Funktion übergeben.
  • Falls die erste Prüfung negativ ausfällt, kommt die zweite WENN-WENN-Kombination zum Einsatz.
  • Zuerst prüfen Sie auf Nichtübereinstimmung mit der ersten Bedingung der ersten Spalte. Dies ist erforderlich, damit keine Werte doppelt in die Berechnung einfließen.
  • Für alle Zeilen, die nicht mit der ersten Bedingung übereinstimmen, prüft die dritte WENN-Funktion den zweiten Bereich auf Übereinstimmung mit der zweiten Bedingung.
  • Bei allen übereinstimmenden Zellen wird der entsprechende Wert ebenfalls an die MITTELWERT-Funktion übergeben.

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"