Listen über Formeln nummerieren

10. März 2010
Martin Althaus Von Martin Althaus, Excel, Office ...

So legen Sie Listennummern per Formel an

Sie möchten Listen nummerieren und die Nummer von der Zellposition abhängig machen? Das ist besonders praktisch, weil die Nummerierung dann immer erhalten bleibt. Auch wenn Sie Daten aus Ihrer Liste löschen oder neue Zeilen einfügen, bleibt die Nummerierung immer korrekt und passt sich sofort an.

Für eine Nummerierung per Formel bieten sich die Tabellenfunktionen ZEILE und SPALTE an. Beide Funktionen benötigen als Argument lediglich einen Zellbezug. Als Ergebnis liefern die Funktionen die entsprechende Zeilen- beziehungsweise Spaltennummer. Wenn Sie die Nummerierung einer Liste mit einem bestimmten Wert beginnen möchten, können Sie die Funktionen ZEILE und SPALTE problemlos mit einer Addition oder Subtraktion kombinieren.

Sofern Sie eine Tabelle erstellen, die erst nach und nach mit Inhalten gefüllt werden soll, können Sie diese so aufbauen, dass Nummerierungen erst dann vergeben werden, wenn Sie in die entsprechende Zeile oder Spalte etwas eingeben. Dazu betten Sie die Funktion ZEILE oder SPALTE in eine Wenn-Abfrage ein, bei der Sie mit der Funktion ISTLEER überprüfen, ob eine Zelle bereits etwas enthält. Die folgende Formel in Zelle A1 bewirkt, dass dort die Zeilennummer 1 erscheint, wenn in B1 etwas eingetragen wird, ansonsten bleibt sie leer:

=WENN(ISTLEER(B1)"";ZEILE())

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"