Listeninformationen aufgliedern

22. Dezember 2009
Martin Althaus Von Martin Althaus, Excel, Office ...

Wie Sie Informationen in Listen zerlegen

In einer umfangreichen Liste werden die Namen von Mitarbeitern, erledigte Aufgaben und die dazugehörigen Zeiten erfasst. Die Liste ist nach Mitarbeiternamen aufsteigend sortiert, sodass alle Einträge eines Mitarbeiters untereinanderstehen. Die folgende Abbildung zeigt den Aufbau der Beispieltabelle:

Neben dieser Tabelle sollen nun nach der Eingabe eines Namens alle Daten zu dem entsprechenden Mitarbeiter aufgelistet werden. Beim vorliegenden Tabellenaufbau stehen die einzelnen Datensätze im Bereich A2:C101. Der Suchbegriff (Name des Mitarbeiters) wird in D2 eingetragen. In E2 ermitteln Sie dann den ersten dazugehörenden Text aus der Spalte B (Aufgabe) mit der folgenden Formel:

=SVERWEIS($D$2;BEREICH.VERSCHIEBEN(A2:$B$101;VERGLEICH($D$2;$A$2:$A$101;0)-1;0);2; FALSCH)

Die folgende Abbildung zeigt den Einsatz dieser Formel:

Diese Formel kopieren Sie ausreichend weit nach unten. Beachten Sie, dass die Formel ab der Zeile, an der für den gesuchten Namen keine Texte mehr gefunden werden, einen Fehler liefert.

Die Anzeige des Fehlerwerts können Sie mit einer WENN-Abfrage abfangen. Diese Abfrage muss überprüfen, ob die Formel einen Fehler liefert. Wenn ja, liefert sie eine leere Zelle, ansonsten führt sie die gewünschte Abfrage aus. Die erweiterte Formel, sieht folgendermaßen aus:

=WENN(ISTFEHLER(SVERWEIS($D$2;BEREICH.VERSCHIEBEN(A2:$B$101;VERGLEICH($D$2;$A$2:$A$101;0)-1;0);2;FALSCH));"";SVERWEIS($D$2;BEREICH.VERSCHIEBEN(A2:$B$101;VERGLEICH($D$2;$A$2:$A$101;0)-1;0);2;FALSCH))

Für die Abfrage der Spalte C (Zeit) verwenden Sie die folgende Formel in Ihrer Tabelle:

=SVERWEIS($D$2;BEREICH.VERSCHIEBEN(A2:$C$101;VERGLEICH($D$2;$A$2:$A$101;0)-1;0); 3 ; FALSCH)

Auch diese Formel können Sie wie oben beschrieben mit einer Fehlerabfrage versehen. Für die Abfrage der weiteren Daten zu einem Mitarbeiter kopieren Sie die Formel ausreichend weit nach unten.

Die folgende Abbildung zeigt die komplette Tabelle mit der Abfrage aller Funktionen in der Beispieltabelle:

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"