Mehrfache Suchkriterien in einer Excel-Liste zählen

13. Dezember 2010
Martin Althaus Von Martin Althaus, Excel, Office ...

So zählen Sie alle Excel-Zellen, die Ihren Kriterien entsprechen

Sie möchten feststellen, wie viele Inhalte einer Liste Ihren Suchkriterien entsprechen und dabei sofort mehrere Kriterien anwenden? Das geht über eine trickreiche Matrixformel. Schauen Sie sich die Tabelle in der Abbildung an:

In den Zellen C1 bis C3 stehen die Kriterien, die Sie anwenden möchten. In Zelle C5 möchten Sie zählen wie viele Datensätze aus der Liste darunter diesen Kriterien entsprechen. Dazu setzen Sie die folgende Matrixformel ein:

=SUMME((B8:B22>=C1)*(A8:A22=C2)*(C8:C22<=C3))

Die Formel geben Sie über die Tastenkombination STRG UMSCHALT EINGABE ein. Excel zeigt anschließend geschweifte Klammern vor und hinter der Formel an. Auch nach jeder Änderung müssen Sie diese Tastenkombination verwenden. Die Formel liefert Ihnen sofort das richtige Ergebnis, wie Sie in der folgenden Abbildung erkennen können:

Sobald Sie die Suchkriterien in den Zellen C1:C3 verändern, passt die Formel auch das Suchergebnis an.

Die Matrixformel setzt sich die Tatsache ein, dass ein WAHR-Wert für Excel der Zahl 1 entspricht und ein FALSCH-Wert der Zahl 0. So können die drei Kriterien in der Matrixformel direkt miteinander multipliziert werden. Nur an den Positionen, an denen in der Ergebnismatrix in allen drei Kriterien eine 1 (also ein WAHR) auftritt, addiert die SUMME-Funktion den Wert 1 zu der Summe.

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"