Minuszeichen in Tabellen nach vorne holen

27. Mai 2009
Martin Althaus Von Martin Althaus, Excel, Office ...

Wie Sie falsche Minuszeichen korrigieren

In Ihrer Tabelle steht das Minuszeichen hinter den passenden Zahlen? Das kann nach dem Import von Zahlen vorkommen.

Beim Import von Daten in eine Tabelle kann es sein, dass bei negativen Zahlen das Minuszeichen nicht links, sondern rechts der Zahl steht. Dann erkennt Excel die Zahlen nicht als Zahlen, sondern geht davon aus, dass es sich um Texte handelt. Das erkennen Sie daran, dass die Inhalte linksbündig in Ihrer Tabelle stehen.

Die Umstellung erledigen Sie am besten in einer neuen Spalte, die Sie rechts der umzuwandelnden anlegen. Wenn die umzuwandelnde Zahl in der Zelle A1 steht, tragen Sie in die Zelle B1 die folgende Formel ein:

=WENN(RECHTS(A1;1)<>"-";A1;TEIL(A1;1;LÄNGE(A1)-1)*-1)

Füllen Sie die Formel in der neuen Spalte nach unten aus, um alle Zahlen umzuwandeln.

Die Formel prüft, ob die Zelle ein Minuszeichen am Ende enthält und isoliert davon abhängig den Teil des Inhalts bis zu diesem Zeichen. Durch die Multiplikation mit -1 wird dieser Wert ein eine negative Zahl umgewandelt.

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"