Monatsanzahl in Monate und Jahre aufteilen

11. Juli 2010
Martin Althaus Von Martin Althaus, Excel, Office ...

Wie teilen Sie Monate in Jahre und Teiljahre auf?

Stellen Sie sich eine Tabelle vor, in der eine bestimmte Anzahl von Monaten in Jahre und Monate aufgeteilt werden soll. So werden aus 27 Monaten zwei Jahre und drei Monate.

Diese Aufgabe ist nicht mit einer einfachen Formel zu bewerkstelligen. Eine Wenn-Abfrage in Kombination mit den Funktionen KÜRZEN und REST macht es aber möglich.

Wenn die in Jahre und Monate aufzuteilende Zahl der Monate in Ihrer Tabelle in der Zelle A1 steht, kommen Sie mit der folgenden Formel zum gewünschten Ergebnis:

=WENN(A1>=12;KÜRZEN(A1/12)&" Jahr"&WENN(KÜRZEN(A1/12)>1;"e";"");"")&WENN(REST(A1;12)>0;WENN(A1>=12;", ";"")&REST(A1;12)&" Monat"&WENN(REST(A1;12)>1;"e";"");"")

Die folgende Abbildung zeigt den Einsatz der Formel in einer Beispieltabelle:

Wenn Sie eine Anzahl von Tagen, die in der Zelle A1 steht, in Wochen und Tage aufteilen möchten, verwenden Sie die folgende Formel:

=WENN(A1>=7;KÜRZEN(A1/7)&" Woche"&WENN(KÜRZEN(A1/7)>1;"n";"");"")&WENN(REST(A1;7);WENN(A1>=7;", ";"")&REST(A1;7)&" Tag"&WENN(REST(A1;7)>1;"e";"");"")

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"