Nulldivision per Formel verhindern

24. März 2010
Martin Althaus Von Martin Althaus, Excel, Office ...

So halten Sie fehlerhafte Divisionsergebnisse fern

Man darf eine Zahl nicht durch 0 teilen. Das Ergebnis ist mathematisch nicht definiert. Wenn Sie es in Excel trotzdem versuchen, erhalten Sie eine Fehlermeldung.

Wenn Sie solche Fehler verhindern möchten, können Sie das fehlerhafte Ergebnis mit einer Formel abfangen. Verwenden Sie dazu eine Kombination aus den Tabellenfunktionen WENN und ISTFEHLER.

Mit der folgenden kleinen Formel können Sie einen solchen Fehlerwert abfangen und festlegen, was stattdessen bei einer Nulldivision geliefert werden soll:

=WENN(ISTFEHLER(B1/B2);"Kein Ergebnis";B1/B2)

Diese Formel gibt den Text "Kein Ergebnis" aus, wenn eine Division nicht definiert ist, ansonsten zeigt sie das Ergebnis der Division an. Die folgende Abbildung zeigt die Formel in der Praxis:

Werden Sie mit unseren Tipps zum Excel-Profi!
Jetzt gratis per E-Mail

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter
  • + Excel-Praxistipps per Mail


Weitere Artikel zum Thema

Newsletter Excel-Praxistipps

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • jederzeit abbestellbar
  • + Excel-Praxistipps per Mail
DDV Qualitätsstandard E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.
Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"