Nur ausgewählte Listeninhalte addieren

31. März 2009
Martin Althaus Von Martin Althaus, Excel, Office ...

Jede zweite Zeile einer Tabelle addieren

Stellen Sie sich eine Tabelle vor, in der Sie in Spalten Summen bilden wollen, bei denen nur jede zweite Zeile berücksichtigt wird.

Denken Sie beispielsweise an eine Liste, in der Umsätze erfasst werden. Dabei sind jedem Tag zwei Zeilen zugeordnet, eine für den Nettoumsatz und eine für die Mehrwertsteuer. Am Monatsende sollen die Nettoumsätze addiert werden. Die folgende Abbildung zeigt eine Beispieltabelle:

Für die gewünschte Addition benötigen Sie eine Matrixformel. In dieser muss überprüft werden, ob sich die Werte in Zeilen mit gerader Zeilennummer befinden oder nicht. Abhängig von dieser Überprüfung wird der Wert dann der Gesamtsumme hinzugefügt oder nicht.

Wenn in der Tabelle die Umsätze der ersten Filiale in Spalte C erfasst sind, stehen in der Zelle C2 die Nettoumsätze des ersten Tags und in Zelle C3 die Mehrwertsteuer dieses Tags.

Die Nettoumsätze erhalten Sie also, wenn Sie die Werte aus den geraden Zeilen addieren; die Mehrwertsteuer steht in den ungeraden Zeilen.

Ob es sich bei einer Zeile um eine gerade oder eine ungerade handelt, erfahren Sie, wenn Sie die Zeilennummer durch 2 teilen und den ganzzahligen Rest betrachten: Bei einer geraden Zeile ist der Rest null, ansonsten nicht.

In der Beispieltabelle soll die Summe der Nettoumsätze in der Zeile 63 addiert werden. Dazu verwenden Sie die folgende Formel:

=SUMME((REST(ZEILE(C2:C61);2)=0)*C2:C61)

Da es sich um eine Matrixformel handelt, müssen Sie die Eingabe mit der Tastenkombination STRG UMSCHALT EINGABE bestätigen. Mit UMSCHALT ist die Taste gemeint, die Sie gedrückt halten müssen, um einen Großbuchstaben einzugeben. Excel setzt die Formel daraufhin in geschweifte Klammern. Die folgende Abbildung zeigt den Einsatz der Matrixformel in der Beispieltabelle:

Wenn Sie stattdessen die Summe der Mehrwertsteuer erhalten möchten, addieren Sie nur die ungeraden Zeilen. Dazu verwenden Sie die folgende Formel, die Sie ebenfalls mit STRH UMSCHALT EINGABE bestätigen müssen:

=SUMME((REST(ZEILE(C2:C61);2)<>0)*C2:C61)

Die folgende Abbildung zeigt den Einsatz der Matrixformel für die Addition der Mehrwertsteuer in der Beispieltabelle:

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"