Review: Excel-Formelwettbewerb

07. November 2008
Martin Althaus Von Martin Althaus, Excel, Office ...

Es gibt zwei Sieger

Liebe Leserin, lieber Leser,

der zweite Excel-Formelwettbewerb ist in dieser Woche zu Ende gegangen. Es zeigt sich, dass auch die scheinbar klare Aufgabenstellung viele verschiedene Fragestellungen aufwirft und eine Vielzahl von Lösungsansätzen bietet.

Als Aufgabe sollte die kürzeste Formel gefunden werden, die "ja" oder "nein" als Ergebnis zurückgibt. Wenn sich im Inhalt von Zelle A1 irgendwo Ziffern befinden, soll das Ergebnis "nein" sein, wenn die Zelle ziffernfrei ist, soll "nein" herauskommen. 123 in Zelle A1 führt zu "ja", ebenso die Inhalte "meinezahl1", "2fast4you" oder andere Text-Ziffernkombinationen. Stehen aber reine Texte, nichts, Fehlerwerte oder etwas anderes Ziffernfreies in Zelle A1, soll die Formel "nein" liefern.

Der Sieger steht fest. Die kürzeste Formel hat 49 Zeichen:

=WENN(ANZAHL(FINDEN(ZEILE(A:A)-1;A1));"ja";"nein")

=WENN(ANZAHL(1*TEIL(A1;ZEILE(A:A);1));"ja";"nein")

Sie sehen: es gibt zwei Sieger! Die erste Formel stammt in der ersten Grundversion von Andreas Lohnecke und wurde von Roger Friebus, Bernd Kohlen und Thomas A. ergänzt und verbessert. Die zweite Formel hat Peter Meindl entwickelt.

Es handelt sich in beiden Fällen um Matrixformeln, die ich Ihnen in dieser Ausgabe weiter unten genauer vorstelle.

Neben der Siegerformel gibt es noch weitere sehr pfiffige Varianten. Und wie viele von Ihnen in der Diskussion auf excellent.exceldaily.de geäußert haben, ist die kürzeste Formel nicht immer die beste. Vor allem aus Geschwindigkeitsgründen bietet es sich an, manchmal nicht die kürzeste Variante einer Formel zu wählen. Auch die Lesbarkeit von Formeln leidet meist unter einer starken Verkürzung, weil sie durch starke Reduzierung immer komplexer werden.

Daher lohnt es sich in jedem Fall, noch einmal in die Ergebnisse des Formel-Wettbewerbs hineinzuschauen. Verwenden Sie den folgenden Link:

http://excellent.mixxt.de/networks/forum/thread.4553

Ich möchte mich bei allen Diskussionsteilnehmern für das Engagement bedanken!

Mit freundlichem Gruß

Ihr

Martin Althaus, Chefredakteur von Excel Daily

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"