So stellen Sie fest, wo sich ein gesuchter Inhalt befindet

14. August 2017
Martin Althaus Von Martin Althaus, Excel, Office ...

Bei ergänzenden Einträgen in Kundenlisten oder anderen Bestandsverwaltungen wird regelmäßig geprüft, ob es sich bei einem Kunden um einen neuen oder um einen bestehenden Kunden handelt. Wie geht das mit Excel?

Das erledigt die folgende Matrixformel, die Ihnen mitteilt, ob ein gesuchter Inhalt in einer Liste enthalten ist:

=WENN(ODER(Suchtext=Suchbereich);
“enthalten“;“nicht enthalten“)

Sie übergeben der Matrixformel die beiden Argumente Suchbereich und Suchtext. Über Suchtext definieren Sie den Inhalt, den Sie suchen. Mit Suchbereich übergeben Sie den zu durchsuchenden Bereich.

Bei der Formel handelt es sich um eine Matrixformel, die Sie nach der Eingabe über die Tastenkombination Strg+Umschalt+Eingabe bestätigen müssen.

Die Formel überprüft jede Zelle des Suchbereichs auf Übereinstimmung mit dem Suchtext. Als Ergebnis liefert die Formel den Text „enthalten“, wenn der Suchtext im Suchbereich enthalten ist. Falls der Suchbereich den Suchtext nicht enthält, gibt die Formel den Text „nicht enthalten“ zurück.

In der abgebildeten Arbeitsmappe liefert die folgende Formel in Zelle D4 als Ergebnis den Text „enthalten“.

=WENN(ODER(C4=$A$4:$A$11);“enthalten“;
“nicht enthalten“)

Das Ergebnis ist korrekt, weil der Text „Huber“ aus Zelle V4 im Bereich A4:A11 enthalten ist. Anstelle der Texte „enthalten“ und „nicht enthalten“ können Sie auch beliebige andere Texte in die Formel einbinden.

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"