Sortierspalte in Excel-Tabelle per Formel ermitteln

03. März 2008
Martin Althaus Von Martin Althaus, Excel, Office ...

 

Wie Sie per Formel feststellen, nach welcher Spalte eine Tabelle sortiert ist

Stellen Sie sich eine Liste mit vielen Spalten vor. In dieser soll geprüft werden, ob die Liste nach einer Spalte sortiert wurde. Wenn ja, soll die Nummer der Spalte ausgegeben werden, nach der sortiert wurde.

Die folgende Abbildung zeigt einen Ausschnitt aus einer Liste in einer Beispieltabelle:

Sortierspalte in Excel 1

Angenommen, der Listenbereich, in dem Sie die sortierte Spalte ermitteln wollen, liegt in den Zellen A2:E31.

Wenn in Ihrer Liste keine Leerzellen vorkommen, tragen Sie die folgende Formel in die Zelle ein, in der die Nummer der Spalte erscheinen soll, nach der die Liste sortiert ist:

=VERGLEICH(ZEILEN(A3:A31);MMULT(MTRANS((A3:E31>=A2:E30)*1);

WENN(ZEILE(2:30);1));0)

Da es sich bei dieser Formel um eine Matrixformel handelt, müssen Sie die Eingabe mit der Tastenkombination STRG SHIFT ENTER bestätigen. (mit SHIFT ist die Taste gemeint, die Sie gedrückt halten müssen, um einen Großbuchstaben zu erreichen, diese Taste wird auch UMSCHALT genannt). Dann stellt Excel die Formel in geschweiften Klammern dar.

In der Ergebniszelle erscheint daraufhin die Nummer der Spalte, nach der die Liste sortiert ist. Wenn die Liste nicht sortiert ist, erhalten Sie als Ergebnis den Fehlerwert #NV. Die folgende Abbildung zeigt das Ergebnis der Berechnung an einer Beispieltabelle:

Sortierspalte in Excel 2

Für den Fall, dass Ihre Liste auch Leerzellen enthalten kann, verwenden Sie die folgende Formel:

=VERGLEICH(ZEILEN(A3:A31);MMULT(MTRANS((WENN(A3:E31<>"";

A3:E31;ZEICHEN(158))>=WENN(A2:E30<>"";A2:E30;ZEICHEN(158)))*1);

WENN(ZEILE(2:30);1));0)

Zur Erläuterung: Leerzeichen werden mit der Formel durch das Zeichen 158 des Ansi-Codes ersetzt. Dieses kommt in der Sortierung an letzter Stelle. Auch bei dieser Formel handelt es sich um eine Matrixformel, die Sie mit der Tastenkombination STRG SHIFT ENTER bestätigen müssen.

Wie bei der ähnlichen Formel ohne Leerzellen erscheint auch in diesem Fall die Nummer der Sortierspalte, der Spalte also, nach der die Liste sortiert ist, in der Ergebniszelle. Falls die Liste nicht sortiert ist, erscheint der Fehlerwert #NV.

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"