Summen abhängig von Kriterien bilden

04. Oktober 2010
Martin Althaus Von Martin Althaus, Excel, Office ...

Wie Sie nur Zahlen addieren, zu denen einer anderen Spalte keine Null steht

Sie möchten die die Werte addieren, die in einem Zellbereich stehen? Dabei sollen aber nur die Werte addiert werden, bei denen in einer anderen Spalte derselben Zeile kein Nullwert zu finden ist? Die folgende Abbildung zeigt, wie eine solche Liste aussehen kann:

Sie möchten nur die Werte aus Spalte A addieren, bei denen in Spalte B ein Nullwert steht.

Diese Aufgabenstellung lösen Sie mit der Funktion SUMMEWENN. Diese addiert alle Zellwerte eines übergebenen Bereichs, die ein vorgegebenes Kriterium erfüllen.

Wenn die zu addierenden Zellen in der Tabelle im Bereich A2:A9 stehen und die Kriterien im Bereich B2:B9 zu finden sind, sieht die benötigte Formel folgendermaßen aus:

=SUMMEWENN(B2:B9;"<>0";A2:A9)

Als ersten Wert übergeben Sie den Bereich, in dem Sie ein Kriterium überprüfen möchten. Als zweites Argument legen Sie das Kriterium fest. Das Kriterium lautet "<>0". Damit werden alle Zellen addiert, deren Kriterium diese Bedingung erfüllt. Mit dem dritten Parameter steuern Sie, aus welchem Zellbereich Excel die Summe bilden soll. Die folgende Abbildung zeigt den Einsatz der Formel in der Praxis:

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"