Tabellenfunktion in Excel-Zelle eintragen

02. Juli 2008
Martin Althaus Von Martin Althaus, Excel, Office ...

Wie Sie Formeln in Excel-Zellen eintragen

Beim Einsatz von Makros ist es immer wieder nötig, Formeln direkt in Zellen von Tabellen einzutragen. Dazu setzen Sie die Eigenschaft Formula ein.

Dieser Eigenschaft weisen Sie die Formel zu, die Sie in einer Zelle einsetzen möchten. Dabei müssen Sie allerdings eine Besonderheit beachten: Beim Einsatz von Tabellenfunktionen müssen Sie den englischen Funktionsnamen einsetzen.

Wenn Sie also beispielsweise die Formel =SUMME(B1:B5) in Zelle A1 der aktiven Tabelle eintragen möchten, setzen Sie das folgende Makro ein:

Sub FormelEintragen()

ActiveSheet.Range("a1").Formula = "=SUM(B1:B5)"

End Sub

Hier steht anstelle des Ausdrucks SUMME der Ausdruck SUM in der Wertzuweisung. Nur dann erhalten Sie das richtige Ergebnis, wie in der folgenden Abbildung zu sehen ist:

rtemagicc_20080702-2bmp.jpg

Beim Einsatz von deutschen Funktionsnamen meldet Excel den Fehler "#NAME?".

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"