Veraltete Excel-Listeninhalte automatisch markieren

16. September 2008
Martin Althaus Von Martin Althaus, Excel, Office ...

So markieren Sie Datensätze mit bestimmten Erfassungsdaten automatisch

Bei der Arbeit mit Listen kommt es immer wieder vor, dass diese mehrere identische Datensätze enthalten, die sich lediglich im Erfassungsdatum unterscheiden. In einer solchen Liste ist es mitunter erforderlich, alle Datensätze zu markieren, für die ein aktuellerer Satz existiert.

Das erreichen Sie bequem über eine Wenn-Abfrage in einer Matrixformel. Die folgende Abbildung zeigt eine Beispieltabelle, in der zu einem Datum jeweils zwei Farbwerte in einer Liste erfasst werden:

Diese Abbildung zeigt nur einen Ausschnitt aus der gesamten Liste. In dieser Liste soll in der Spalte D der Text „veraltet“ erscheinen, wenn für eine Farbkombination ein aktuellerer Satz existiert. Dazu tragen Sie in die Zelle D2 die folgende Formel ein:

=WENN(C2=MAX(WENN(A$2:A$51&B$2:B$51=A2&B2;C$2:C$51));"";"veraltet")

Da es sich bei der Formel um eine Matrixformel handelt, die einen Zellbereich durchsucht, müssen Sie die Eingabe mit der Tastenkombination STRG UMSCHALT EINGABE bestätigen. UMSCHALT ist die Taste, die Sie gedrückt halten müssen, um einen Großbuchstaben zu erhalten, sie wird auch SHIFT genannt.

Nach Einsatz der Tastenkombination erscheint die Formel in geschweiften Klammern in der Zelle:

Diese Formel kopieren Sie anschließend in der Spalte D nach unten bis zur letzten Zeile der Liste. Das Ergebnis sieht dann folgendermaßen aus:

Überall dort, wo in der Liste neuere Einträge für das Wertepaar aus den Spalten A und B enthalten ist, erscheint nun automatisch der Text "veraltet" in Spalte D.

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"