Verschiedene Werte für dasselbe Datum in einer Excel-Liste zählen

26. Mai 2011
Martin Althaus Von Martin Althaus, Excel, Office ...

Um herausfinden, wie viele Werte mit bestimmten Datumskriterien sich in einer Excel-Liste befinden, bestimmen Sie die Anzahl über eine trickreiche Formel

Das Zählen der Datensätze per Matrixformel

Das Zählen der Datensätze per Matrixformel

In einer Tabelle mit Messergebnissen soll ermittelt werden, wie oft ein Kürzel an einem vorgegebenen Datum vorkommt. Dabei kann die Tabelle sowohl mehrere Zeilen mit dem gleichen Datum als auch mehrere Zeilen mit dem gleichen Kürzel enthalten.

Die folgende Abbildung zeigt einen Ausschnitt aus einer Beispieltabelle:

Beispieltabelle mit Datumswerten und zugehörigen Zahlen

Für die Lösung dieser Aufgabe benötigen Sie eine zusätzliche Hilfsspalte. Diese legen Sie rechts neben der eigentlichen Tabelle an, im vorliegenden Beispiel in der Spalte E.

Zudem ist es sinnvoll, die Frage, welches Kürzel an welchem Datum vorkommt, variabel zu halten. Dazu werden im Beispiel die Zellen G1 und G2 verwendet. In diese Zellen werden dann das zu suchende Datum und das zu suchende Kürzel eingetragen.

Die folgende Abbildung zeigt den Tabellenausschnitt mit eingerichteten Hilfsspalten und -zellen:

Hilfsspalten und Hilfszellen für Nebenrechnungen

Im ersten Schritt müssen die Zellen mit Datum und Kürzel Zeile für Zeile miteinander verglichen werden. Dafür eignet sich die Funktion UND in der Hilfsspalte.

Für den Vergleich in der ersten Zeile tragen Sie die folgende Formel in die Zelle E2 ein:

=UND(A2=$G$1;D2=$G$2)

Die folgende Abbildung zeigt die Formel in der Tabelle:

UND-Funktion in der Datumstabelle

Mit der Funktion UND wird verglichen, ob das Datum aus A2 mit dem in G1 übereinstimmt und ob das Kürzel aus D2 mit dem in Zelle G2 übereinstimmt. Trifft das zu, gibt die Funktion WAHR aus, ansonsten FALSCH. Die UND-Funktion kopieren Sie dann in die darunter liegenden Zellen in der Hilfsspalte, um den Vergleich für alle Zeilen der Tabelle durchzuführen.

Da in die Zellen G1 und G2 noch keine Vergleichswerte eingegeben wurden, steht nun in allen Zellen der Hilfsspalte der Wert FALSCH. Wenn Sie Vergleichswerte eintragen, erscheint bei Übereinstimmungen der Wert WAHR.

Um zu ermitteln, wie oft nun Kürzel und Datum übereinstimmen, müssen die WAHR-Werte in der Tabelle gezählt werden. Dazu verwenden Sie die Funktion ZÄHLEWENN. Tragen Sie in die Zelle, in der die Anzahl der Übereinstimmungen erscheinen soll, die folgende Formel ein:

=ZÄHLENWENN(E2:E1000;WAHR)

In der Zelle erscheint dann das Ergebnis. Die folgende Abbildung zeigt, wie das am Beispiel aussieht:

Die Anzahl der Datensätze in der Excel-Tabelle

Mitunter können Hilfsspalten in Tabellen störend sein. In solchen Fällen bietet es sich an, die Hilfsspalten auszublenden. Alternativ können Sie eine Matrixformel verwenden, um die Anzahl der Datensätze zu berechnen. Diese Matrixformel kommt ganz ohne die Hilfsspalte aus:

=SUMME(WENN((A2:A1000=G1)*(D2:D1000=G2);1))

Dieser Matrixformel geben Sie nicht über die Taste EINGABE, sondern über die Tastenkombination STRG UMSCHALT EINGABE ein, damit sie funktioniert. Auch nach jeder Änderung der Formeln müssen Sie diese Tastenkombination verwenden. Die folgende Abbildung zeigt die Formel in der Praxis. Sie liefert das gleiche Ergebnis wie die Formel darüber.

Das Zählen der Datensätze per Matrixformel

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"