Wie Sie feststellen, ob eine Excel-Formel einen Fehler enthält

15. November 2011
Martin Althaus Von Martin Althaus, Excel, Office ...

So können Sie Fehler in Ihren Excel-Listen und Berechnungen per Formel erkennen

Die Funktion WENNFEHLER im Einsatz

Die Funktion WENNFEHLER im Einsatz

Möchten Sie über eine Formel feststellen, ob sich in einer Zelle ein Fehler befindet oder nicht? Das ist praktisch, wenn Sie formelgesteuert auf Fehler in Ihren Arbeitsmappen reagieren möchten.

Bis zur Excel-Version 2003 verwenden Sie für die Überprüfung, ob eine Formel einen Fehler liefert, eine Wenn-Abfrage. Sie sieht beispielsweise folgendermaßen aus:

=WENN(ISTFEHLER(A2/B2);"";A2/B2)

Bei einem Fehler liefert diese Formel eine leere Zelle als Ergebnis. Dabei wird die Operation A2/B2 auf einen Fehler überprüft. Wenn die Berechnung fehlerfrei durchgeführt werden kann, erhalten Sie das entsprechende Ergebnis.

In Excel 2007 und Excel 2010 können Sie die Aufgabe mit der Funktion WENNFEHLER erledigen. Die folgende Formel ersetzt die obige Wenn-Abfrage:

=WENNFEHLER(A2/B2;"")

Die folgende Abbildung zeigt den Einsatz von WENNFEHLER:

Die Funktion WENNFEHLER im Einsatz

Auch die Variante mit der Kombination aus WENN und ISTFEHLER funktioniert in Excel 2007 und Excel 2010 weiterhin.

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"