Wie Sie mit einer Formel zwei Datenbestände durchsuchen

24. Juli 2016
Martin Althaus Von Martin Althaus, Excel, Office ...

Sie möchten Werte über Formeln aus Ihren Tabellen auslesen? Ganz trickreich können Sie Daten auch gleichzeitig in zwei verschiedenen Listen suchen und aufspüren.

Die Funktion SVERWEIS bietet Ihnen eine professionelle Methode, um Daten aus Ihren Listen schnell und bequem abzufragen. Mit der Funktion können Sie festlegen, dass Sie nach einer exakten Übereinstimmung mit dem Suchbegriff suchen. Die Liste muss dann auch nicht sortiert vorliegen. Wenn der Begriff nicht gefunden wird, liefert Excel einen Fehlerwert.

Falls die gesuchte Information aber nicht nur in einer Liste, sondern in einer von zweien auftreten kann, möchten Sie im Falle eines solchen Fehlerwertes in einer zweiten Liste nach dem Suchwert suchen. Das erledigen Sie über die folgende Formel:

=WENN(ISTFEHLER(SVERWEIS(Suchbegriff;Liste1;Spalte1;0));SVERWEIS(Suchbegriff;Liste2;Spalte2,0);SVERWEIS(Suchbegriff; Liste1;Spalte1;))

Sie übergeben der Formel fünf Argumente, um den gesuchten Inhalt aus einer der beiden Listen zu ermitteln:

  • Mit Suchbegriff übergeben Sie den Suchbegriff, nachdem Sie in den beiden Listen suchen möchten.
  • Die beiden Argumente Liste1 und Liste2 definieren die beiden Listenbereiche, in denen Sie nach dem Suchbegriff suchen möchten.
  • Über Spalte1 und Spalte2 legen Sie fest, aus welcher Spalte der jeweiligen Liste das Ergebnis geliefert werden soll. 

Als Ergebnis liefert die Formel das zu dem Suchbegriff gehörende Ergebnis aus der übergebenen Spalte. Falls der Suchbegriff in beiden Listen auftreten sollte, findet die Formel ihn in der ersten Liste. Einen Fehlerwert liefert die Formel dann, wenn der Suchbegriff in keiner der beiden Listen auftritt. Ein Vorteil der Formel liegt darin, dass die beiden Listen weder gleich aufgebaut sein noch dieselbe Größe besitzen müssen.

Im abgebildeten Arbeitsblatt liefert die folgende Formel in Zelle B6 als Ergebnis den Wert „109.000“:

=WENN(ISTFEHLER(SVERWEIS(E5;A5:B9;2;0));SVERWEIS(E5;A13:B17;2;0);SVERWEIS(E5;A5:B9;2;0))

Das Ergebnis „109.000“ resultiert daraus, dass der Suchwert „Ulm“ aus Zelle E5 nicht in der ersten Liste des Bereichs A5:B9 gefunden wird. Deshalb sucht die Formel ihn anschließend noch in der zweiten Liste des Bereichs A13:B17. Dort findet sie zu „Ulm“ in der zweiten Spalte den gelieferten Wert „109.000“.

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"