Wie Sie verteilte Datensätze zu einer Einheit kombinieren

02. August 2016
Martin Althaus Von Martin Althaus, Excel, Office ...

Importierte Daten liegen selten in der Form vor, in der Sie sie in Excel weiterverarbeiten möchten. Falls zusammengehörende Daten auf mehrere Zellen aufgeteilt wurden, ist das besonders ärgerlich. Über eine spezielle Formel können Sie Ihre Daten aber schnell und bequem wieder zusammenführen.

Stehen importierte Daten in Zellen untereinander statt nebeneinander? Die folgende Formel behebt das Problem und kombiniert die Inhalte von vier zusammengehörenden Zellen zu einem neuen Datensatz: 

=WENN(REST(ZEILE()-ZEILE(ErsteZelle)+1; 4)=0;VERKETTEN(Zelle1;” “;Zelle2;” “; Zelle3;” “;Zelle4);””)

Sie übergeben der Formel fünf Argumente: Mit ErsteZelle übergeben Sie die erste Zelle des Spaltenbereichs, dessen Daten Sie zusammenführen möchten. Übergeben Sie ErsteZelle als absoluten Bezug. Mit den Argumenten Zelle1 bis Zelle4 übergeben Sie die vier untereinander­ liegenden Zellen, die zusammengefasst werden sollen.

Geben Sie die Formel neben dem zusammenzufassenden Bereich ein und kopieren Sie die Formel nach der Eingabe in jede Zeile dieses Bereichs. Als Ergebnis liefert die For­ mel für alle vier Zeilen jeweils den zusammengefassten Inhalt der vier darüberliegenden Zeilen. Getrennt wer­ den die Inhalte jeweils durch ein Leerzeichen.

Falls Sie die Inhalte durch ein anderes Zeichen trennen möchten, ersetzen Sie die Leerzeichen innerhalb der VERKETTEN-Funktion.

Falls Sie mehr oder weniger als vier Zeilen zu­sammenfassen möchten, ersetzen Sie in der REST­Funktion den Wert 4 und ändern Sie die Anzahl der verketteten Bezüge in der VERKETTEN-­Funktion.

In der abgebildeten Arbeitsmappe liefert die folgende Formel in Zelle B7 das Ergebnis „Daten 1 100 Berlin Schmidt“:

=WENN(REST(ZEILE()-ZEILE($A$4)+1;4)=0; VERKETTEN(A4;” “;A5;” “;A6;” “;A7);””)

Die Formel verkettet die Inhalte der Zellen A4 bis A7.

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"