Zählen Sie Buchstaben und Textteile

31. Oktober 2009
Martin Althaus Von Martin Althaus, Excel, Office ...

Wie Sie Platzhalter beim Zählen mit Bedingungen einsetzen

In einer Excel-Tabelle werden Zahlenwerte mit den Buchstaben A, B, C zur Kategorisierung versehen. Das System macht es möglich, dass einem Wert mehr als ein aber auch gar kein Buchstabe zugeordnet werden kann.

In einem anderen Bereich des Tabellenblatts soll nun die Anzahl des Vorkommens der Kategorienbuchstaben mit einer Formel ausgegeben werden.

Wenn Sie versuchen, diese Aufgabenstellung mit der Funktion ZÄHLENWENN und den jeweiligen Buchstaben als Suchkriterium zu lösen, werden Sie schnell feststellen, dass diese Variante zu falschen Ergebnissen führt.

Bei der Art der Berechnung werden nur die Buchstaben berücksichtigt, die allein in einer Zelle stehen. Jede Kombination mit einem oder zwei anderen Buchstaben wird bei der Zählung ignoriert.

Die Lösung dieses Problems ist wenig bekannt, allerdings ganz einfach: Die Funktion ZÄHLENWENN akzeptiert auch Platzhalterzeichen als Suchkriterium. Wenn Sie ein Sternchen (*) vor und hinter den gesuchten Buchstaben setzen, werden alle Vorkommen mit anderen Buchstaben mitgezählt.

Wenn die Kategorienbuchstaben im Zellbereich B2:B20 stehen und der Buchstabe A gezählt werden soll, verwenden Sie dazu die folgende Formel:

=ZÄHLENWENN(B2:B20;"*A*")

Die folgende Abbildung zeigt den Einsatz dieser Formel an einem Beispiel:

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"