Zahlen bei der Mittelwert-Berechnung ausschließen

30. April 2010
Martin Althaus Von Martin Althaus, Excel, Office ...

Sie möchten den Mittelwert einer Datenreihe berechnen, dabei aber bestimmte Werte unberücksichtigt lassen? Die folgende Abbildung zeigt, wie eine solche Datentabelle aussehen kann:

Aus der Spalte A soll nun der Mittelwert ermittelt werden. Dabei sollen nur die Werte der Spalte A berücksichtigt werden, bei denen in der gleichen Zeile in der zweiten Spalte B auch ein Wert steht.

Diese Aufgabenstellung lösen Sie mit einer Matrix-Formel, in der die Funktionen MITTELWERT und WENN miteinander kombiniert werden. Wenn die beiden Spalten im Bereich A1:B25 stehen, verwenden Sie die folgende Formel:

=MITTELWERT(WENN(B1:B25>0;A1:A25;""))

Damit die Formel funktioniert, müssen Sie sie über die Tastenkombination STRG SHIFT ENTER eingeben (mit SHIFT ist die Taste gemeint, die Sie gedrückt halten müssen, um einen Großbuchstaben zu erreichen, diese Taste wird auch UMSCHALT genannt). Dann stellt Excel die Formel in geschweiften Klammern dar.

Auch nach einer Änderung der Formel müssen Sie immer die Tastenkombination STRG SHIFT ENTER verwenden, um die Formel einzugeben. In der Zelle erscheint nach der Bestätigung das gewünschte Ergebnis. Die folgende Abbildung zeigt, wie das aussehen kann:

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"