Zeitdifferenzen fehlerfrei bilden

11. Juni 2010
Martin Althaus Von Martin Althaus, Excel, Office ...

Vorsicht beim Einsatz der 1904-Datumswerte

In einer Tabelle werden tägliche Einsatzzeiten erfasst. Für jeden Tag wird mit einer einfachen Subtraktion die Differenz zum Vortag ermittelt. Bei negativen Differenzen liefert Excel nicht den gewünschten Wert, sondern füllt die Zelle mit dem Zeichen #. Die folgende Abbildung zeigt ein Beispiel:

Die vermeintliche Lösung liegt nun darin, die Datumswerte für Excel auf 1904-Datumswerte umzustellen. Diese Option bietet Excel eigentlich nur aus Gründen der Kompatibilität zu anderen Kalkulationsprogrammen an. Sie bewirkt, dass Excel die Zählung der Tage für die Datumsberechnung nicht wie üblich am 1. Januar 1900 beginnt, sondern am 1. Januar 1904.

Für die Umstellung der Datumswerte rufen Sie im Menü "Extras" den Befehl "Optionen" auf. In Excel ab Version 2007 drücken Sie die Office-Schaltfläche und klicken auf "Excel-Optionen". In der erscheinenden Dialogbox aktivieren Sie im Register "Berechnung" die Option "1904-Datumswerte" Wie die folgende Abbildung zeigt, ist das Problem der Darstellung negativer Zeitangaben damit behoben:

Diese Lösung funktioniert aber nur auf den ersten Blick. Wir haben die kleine Beispieltabelle absichtlich in der ersten Spalte mit einem Datum versehen, um das Problem zu verdeutlichen.

Sie sehen, dass die Umstellung der Datumswerte dazu geführt hat, dass alle Datumswerte um vier Jahre und einen Tag in die Zukunft verschoben wurden.

Hätte die Tabelle an dieser Stelle statt der Datumsangaben nur die Angabe der Wochentage beinhaltet, würde der Fehler in anderen Zellen womöglich gar nicht oder erst viel später auffallen.

Verschärft wird das Problem noch dadurch, dass alle Datumswerte, die nach der Umstellung eingegeben werden, korrekt dargestellt werden. Das führt zu einem Datums-Mix, der oft nicht mehr korrigiert werden kann.

Lösen können Sie das Problem der negativen Zeiten aber auch ohne Zeitumstellung. Das geht zum Beispiel durch die Aufteilung von Plus- und Minus-Differenzen auf zwei Spalten.

Im Beispiel sind das die Spalten C und D. Tragen Sie die folgende Formel in die Zelle C11 ein:

=WENN(B11>B10;B11-B10;"")

Dann geben Sie die folgende Formel in die Zelle D11 ein:

=WENN(B11<B10;B10-B11;"")

Anhand eines Größenvergleichs ermitteln diese Formeln, ob ein positives bzw. negatives Ergebnis geliefert wird, und tragen dieses in die entsprechende Zelle ein.

Beide Formeln kopieren Sie ausreichend weit nach unten. Die Ergebniszellen formatieren Sie dann noch im Format "hh:mm", damit die Zeiten in der gewünschten Form angezeigt werden.

Die folgende Abbildung zeigt das Ergebnis der Berechnungen in der Beispieltabelle:

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"