Zeiten aus Listen zusammenfassen

11. Oktober 2010
Martin Althaus Von Martin Althaus, Excel, Office ...

Nur Wochenendstunden in einer Liste addieren

In einer Liste werden Arbeitsstunden erfasst. Für eine Auswertung sollen nur die Stunden addiert werden, die an einem Wochenende eingetragen wurden. Die Liste ist folgendermaßen aufgebaut:

In der Spalte A stehen die Wochentage,  mit zwei Buchstaben abgekürzt. In der Spalte B sind die dazugehörigen Stunden eingetragen.

Grundsätzlich lässt sich diese Aufgabe mit verschiedenen Funktionen lösen. Besonders kurz und trickreich ist aber der Einsatz der Funktion SUMMENPRODUKT in Kombination mit der Funktion LINKS.

In der Beispieltabelle stehen die abgekürzten Wochentage in A1:A31 und die Stunden in B1:B31. Die folgende Formel ermittelt dann die Summe der Stunden an Wochenenden:

=SUMMENPRODUKT((LINKS(A1:A31;1)="S")*(B1:B31))

Dabei arbeitet die Funktion mit der Tatsache, dass man die Wochenenden daran erkennen kann, dass sie als einzige Wochentagsnamen mit einem "S" beginnen. Genau dieses Zeichen wird als Unterscheidungskriterium genutzt. Die folgende Abbildung zeigt den Einsatz dieser Formel in einer Beispieltabelle.

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"