Ziffern in einer Excel-Zelle zählen

11. Dezember 2008
Martin Althaus Von Martin Althaus, Excel, Office ...

So ermitteln Sie die Anzahl der Ziffern in einer Zelle

Stellen Sie sich eine Tabelle vor, in der in Zellen Inhalte stehen, die sich aus Ziffern und Buchstaben zusammensetzen.

In diesen Zellen sollen nun die in einer Zelle enthaltenen Ziffern gezählt werden. Buchstaben oder andere Zeichen sollen dabei ignoriert werden.

Mit einer der integrierten Funktion können Sie diese Aufgabe nicht lösen. Sie benötigen eine Formel, in der die Funktionen SUMME, ISTZAHL, TEIL und SPALTE miteinander kombiniert werden. Wenn Sie die Ziffern in der Zelle A1 zählen wollen, sieht die Formel folgendermaßen aus:

=SUMME(ISTZAHL((TEIL(A1;SPALTE(1:1);1)*1))*1)

Da es sich bei dieser Formel um eine Matrixformel handelt, müssen Sie die Eingabe mit der Tastenkombination STRG UMSCHALT EINGABE bestätigen.

Die folgende Abbildung zeigt den Einsatz der Matrixformel in einer Beispieltabelle:

Wenn Sie nicht die Ziffern in einer einzelnen Zelle, sondern in einem Zellbereich zählen wollen, verwenden Sie die folgende Formel:

=SUMME(ISTZAHL((TEIL(A1:A100;SPALTE(1:1);1)*1))*1)

Auch die Eingabe dieser Formel müssen Sie mit der Tastenkombination STRG UMSCHALT EINGABE bestätigen, da es sich um eine Matrixformel handelt. Auch nach jeder Änderung verwenden Sie bitte diese Tastenkombination, um die Änderungen zu übernehmen.

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"