Bedingter Mittelwert in Calc

23. April 2015
Achim Wagenknecht Von Achim Wagenknecht, Freeware & Open Source, News & Trends, Linux, OpenOffice, Picasa, GIMP, Multimedia ...

Sie möchten einige Werte in eine Rechnung einbeziehen, andere aber nicht. Mit der Wenn-Funktion geht das.

Windows+Linux / Deutsch / Open Source. Eine Firma wickelt kleine und große Aufträge ab. als "klein" gilt hier ein Auftrag, wenn er unter 10.000 Euro liegt. Alle Buchungen werden in einer einzigen Calc-Tabelle erfasst. Daraus soll nun die Summe und der Mittelwert der "kleinen" Aufträge ermittelt werden. Allgemein formuliert geht es darum, Werte abhängig von einer Bedingung in eine Berechnung einzubeziehen - oder eben nicht. In ähnlicher Form können auch andere Bedingungen in Berechnungen einfließen, zum Beispiel, um Umsätze während der Woche von denen am Wochenende zu unterscheiden.

Nehmen wir an, die ursprünglichen Werte stehen in der Spalte A. Damit diese nur einfließen, wenn die Bedingung zutrifft, erzeugen Sie mit der WENN-Funktion in Spalte B eine Eins, wenn die Bedingung wahr ist und eine Null, wenn sie falsch ist:
=WENN(A2<10000;1;0)

In Spalte C multiplizieren Sie die Werte aus A und B:
=A2*B2

C enthält jetzt die ursprünglichen Werte für den Fall, dass die Bedingung zutrifft, ansonsten Nullen. Mit diesen Werten können Sie nun weiter rechnen.

Für unser Beispiel bilden Sie für die Spalten B und C die Summen und teilen die Summe der Spalte C durch die Summe der Spalte B. Damit haben Sie den Mittelwert aller Beträge, die unter 10.000 Euro liegen. Die Funktion MITTELWERT kann man an dieser Stelle nicht anwenden, weil sie die Nullen mit einbeziehen und damit das Ergebnis verfälschen würde.

Mehr zum Thema:Wochenende ermitteln in Calc

So nutzen Sie endlich alle Office-Möglichkeiten!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Windows-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"