Anzahl verschiedener Werte in einer Excel-Liste ermitteln

27. Januar 2009
Martin Althaus Von Martin Althaus, Excel, Office ...

So bestimmen Sie die Datenstreuung in Ihren Listen

Wenn Sie ermitteln möchten, wie viele unterschiedliche Werte eine Liste enthält, können Sie dazu nicht auf eine der integrierten Tabellenfunktionen zurückgreifen.

Mit einer Formel, in der Sie die Funktionen SUMME, WENN und HÄUFIGKEIT miteinander kombinieren, kommen Sie trotzdem zum gewünschten Ergebnis. Das geht so:

Stellen Sie sich eine Beispieltabelle vor, in der im Zellbereich A1:C10 Werte eingetragen sind. In Zelle E1 soll ermittelt werden, wie viele unterschiedliche Werte im Zellbereich A1:C10 stehen.

Dieses Ergebnis liefert Ihnen die folgende Formel:

=SUMME(WENN(HÄUFIGKEIT(A1:C10;A1:C10)>0;1))

Die folgende Abbildung zeigt den Einsatz dieser Formel in einer Beispieltabelle:

Mit der Funktion WENN überprüft die Formel, ob eine Zahl ermittelt wird, deren Häufigkeit in der Liste größer als Null ist. Dann wird der Funktion SUMME der Wert 1 übergeben, ansonsten 0.

Die Summe ergibt dann die gewünschte Anzahl der in der Liste im Zellbereich A1:C10 enthaltenen unterschiedlichen Werte.

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"