Ein Ergebnis nur ausgeben, wenn eine andere Excel-Zelle einen bestimmten Inhalt besitzt

27. Juni 2008
Martin Althaus Von Martin Althaus, Excel, Office ...

So setzen Sie Bedingungen in Excel ein

Sie möchten dafür sorgen, dass eine Formel nur dann ausgerechnet wird, wenn in einer bestimmten Zelle ein bestimmter Wert zu finden ist? Das geht über die WENN-Funktion.

Stellen Sie sich vor, Sie möchten zu einem Endpreis unter Umständen einen Rabatt gewähren. Wenn in einer bestimmten Zelle der Text "Ja" steht, soll ein Rabatt von 5% gewährt werden, ansonsten nicht. Die folgende Abbildung zeigt die Situation:

rtemagicc_20080627-3bmp.jpg

Der Endpreis soll in Zelle B3 stehen. Dort wird der Wert aus Zelle B1 mit einem Abschlag von 5% übernommen, falls in Zelle B2 der Text "Ja" zu finden ist. Ansonsten soll der Wert aus Zelle B1 unverändert in Zelle B3 auftauchen. Die passende Excel-Formel für Zelle B3 lautet:

=WENN(B2="Ja";B1*95%;B1)

Über die WENN-Abfrage legen Sie zuerst eine Bedingung fest. Das ist hier der Ausdruck B2="Ja". Wenn diese Bedingung erfüllt ist (wenn also in Zelle B2 der Text "Ja" steht), trägt Excel den Ausdruck hinter der Bedingung in die Zelle ein. Das ist die Formel B1*95%.

Ist die Bedingung nicht erfüllt, wird der dritte Parameter in die Zelle übernommen. Der Ausdruck B1 sorgt hier dafür, dass die Zahl ohne Rabatt in Zelle B3 übernommen wird.

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"