Zeichen und Ziffern in Ihren Excel-Tabellen zählen

24. November 2011
Martin Althaus Von Martin Althaus, Excel, Office ...

So finden Sie heraus, wie oft sich bestimmte Zeichen oder Ziffern in einem Zellbereich befinden

So zählen Sie Zahlen und Ziffern in einem Zellbereich

So zählen Sie Zahlen und Ziffern in einem Zellbereich

Möchten Sie herausfinden, wie oft sich bestimmte Zeichen oder Ziffern in einem bestimmten Bereich einer Excel-Tabelle befinden? Wenn Sie versuchen, diese Aufgabenstellung mit der Funktion ZÄHLENWENN und den jeweiligen Buchstaben als Suchkriterium zu lösen, werden Sie schnell feststellen, dass diese Variante zu falschen Ergebnissen führt.

Bei der Art der Berechnung werden nur die Buchstaben berücksichtigt, die allein in einer Zelle stehen. Jede Kombination mit einem oder zwei anderen Buchstaben wird bei der Zählung ignoriert.

Zur Lösung verwenden Sie Platzhalterzeichen als Suchkriterium. Wenn Sie ein Sternchen (*) vor und hinter den gesuchten Buchstaben setzen, werden alle Vorkommen mit anderen Buchstaben mitgezählt.

Um beispielsweise zu zählen, in wie vielen Zellen im Bereich A2:A25 der Buchstabe C mindestens einmal vorkommt, setzen Sie die folgende Formel ein

=ZÄHLENWENN(A2:A25;"*C*")

Die folgende Abbildung zeigt den Einsatz dieser Formel an einem Beispiel:

So zählen Sie Zahlen und Ziffern in einem Zellbereich

Sie können das Verfahren nicht nur mit Buchstaben, sondern auch mit Zahlen verwenden. Die Formel unterscheidet nicht zwischen Kleinbuchstaben und Großbuchstaben.

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"