Mehrere Bedingungen in einer WENN-Formel
© sdecoret - Adobe Stock

Mehrere Bedingungen in einer WENN-Formel

Sie möchten Ergebnisse davon abhängig machen, ob mehrere Voraussetzungen in Ihren Tabellen erfüllt sind? Im folgenden Artikel finden Sie zwei Beispiel, mit denen Sie lediglich die Ergebnisse ausspielen, die Ihre Bedingungen erfüllen.

Ergebnisse in Excel-Tabelle nach Bedingungen filtern

Stellen Sie sich vor, Sie addieren in Spalte D die Werte der Spalten A, B und C. In der Spalte E soll das Berechnungsergebnis aus Spalte D nur dann ausgegeben werden, wenn in den Spalten A bis C vorgegebene Werte stehen. Ansonsten soll der Text "nichts" ausgegeben werden. Wie können Sie das mit einer Wenn-Abfrage realisieren?

Diese Aufgabenstellung können Sie lösen, wenn Sie die Bedingungen in der Abfrage mit der Funktion UND verknüpfen. Für Zeile 1 tragen Sie die folgende Formel in Zelle E1 ein:

=WENN(UND(A1=“x“;B1=“y“;C1=“z“);D1;“nichts“)

Das Ergebnis aus D1 wird nur übernommen, wenn die drei Bedingungen erfüllt sind. Im anderen Fall wird gemäß der Vorgaben in der Formel „nichts“ eingetragen. Anstelle des Bezugs auf die Zelle D1 können Sie selbstverständlich auch eine Formel für die direkte Berechnung in die Formel eintragen.

Die folgende Abbildung zeigt den Einsatz der Formel in einer Beispieltabelle:

 

So ermitteln Sie Daten in Excel-Listen nach bestimmten Kriterien

So filtern Sie Listen nach zwei Kriterien und ermitteln die Anzahl von Daten, die zwei verschiedene Kriterien erfüllen

Mit der Funktion ZÄHLENWENN können Sie sehr komfortabel die Elemente einer Liste zählen, die einem vorgegebenen Kriterium entsprechen. Problematisch wird es, wenn Sie versuchen, dabei zwei Bedingungen mit der Funktion UND zu verknüpfen.

Denken Sie beispielsweise an eine Liste, in der Sie alle Zellen zählen wollen, deren Inhalt größer als 20 und kleiner als 80 ist.

Bei der Verknüpfung dieser beiden Bedingungen werden Sie bemerken, dass die Berechnung grundsätzlich das Ergebnis null liefert. Das liegt daran, dass die Funktion ZÄHLENWENN nur auf die Verwendung mit einer Bedingung ausgerichtet ist.

Mit einem kleinen Trick können Sie die Funktion jedoch trotzdem für die beschriebene Aufgabe nutzen.

Für die Lösung der Aufgabe verwenden Sie zweimal die Funktion ZÄHLENWENN. Zuerst werden alle Werte gezählt, die größer als 20 sind. Von diesem Ergebnis wird dann die Anzahl der Werte subtrahiert, die größer oder gleich 80 sind.

Wenn die Liste mit den Werten im Bereich A1:A20 steht, sieht die Formel in der Ergebniszelle – im folgenden Beispiel die Zelle B1 – folgendermaßen aus:

=ZÄHLENWENN(A1:A20;">20")-ZÄHLENWENN(A1:A20;"">=80)

Die folgende Abbildung zeigt den Einsatz der ergänzten Formel in einer Tabelle mit der Ergebniszelle B1: