Anzahl verschiedener Werte in einer Excel-Liste ermitteln

Anzahl verschiedener Werte in einer Excel-Liste ermitteln

So bestimmen Sie die Datenstreuung in Ihren Listen

Wenn Sie ermitteln möchten, wie viele unterschiedliche Werte eine Liste enthält, können Sie dazu nicht auf eine der integrierten Tabellenfunktionen zurückgreifen.

Mit einer Formel, in der Sie die Funktionen SUMME, WENN und HÄUFIGKEIT miteinander kombinieren, kommen Sie trotzdem zum gewünschten Ergebnis. Das geht so:

 

Stellen Sie sich eine Beispieltabelle vor, in der im Zellbereich A1:C10 Werte eingetragen sind. In Zelle E1 soll ermittelt werden, wie viele unterschiedliche Werte im Zellbereich A1:C10 stehen.

Dieses Ergebnis liefert Ihnen die folgende Formel:

=SUMME(WENN(HÄUFIGKEIT(A1:C10;A1:C10)>0;1))

Die folgende Abbildung zeigt den Einsatz dieser Formel in einer Beispieltabelle:

Mit der Funktion WENN überprüft die Formel, ob eine Zahl ermittelt wird, deren Häufigkeit in der Liste größer als Null ist. Dann wird der Funktion SUMME der Wert 1 übergeben, ansonsten 0.

Die Summe ergibt dann die gewünschte Anzahl der in der Liste im Zellbereich A1:C10 enthaltenen unterschiedlichen Werte.