Formel per Makro in Zelle eintragen

18. April 2010
Martin Althaus Von Martin Althaus, Excel, Office ...

So fügen Sie eine Formel in einer Zelle ein

Möchten Sie Formeln per Makro in eine Zelle eintragen? Normalerweise ist die Eingabe einer Formeln über die Benutzeroberfläche von Excel der einfachere Weg, aber in machen Fällen ist es erforderlich, Formeln automatisch anzulegen.

Das können Sie erreichen, indem Sie die Eigenschaft FormulaLocal verwenden. Sie erlaubt es, eine Formel in der nationalen Schreibweise in eine Zelle einzutragen. Das folgende Makro zeigt, wie das geht:

Sub FuegeFormelEin()
ActiveCell.FormulaLocal = "=SUMME(B1:B50)"
End Sub

Das Makro setzt die Formel SUMME(B1:B50) in die aktive Zelle ein. Wenn das beim Start des Makro beispielsweise Zelle A1 war, zeigt die folgende Abbildung, wie das Ergebnis aussieht:

Sie können die Eigenschaft FormulaLocal auch verwenden, um eine Formel in der nationalen Schreibweise aus einer Zelle auszulesen.

Tipp: Falls Sie wissen möchten, wie Sie Makros in Excel eingeben und starten, finden Sie hier eine Kurzbeschreibung: www.exceldaily.de/excel-makros-vba/artikel/d/so-geben-sie-makros-in-excel-ein.html

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"